0
\$\begingroup\$

I have a design with several rooms in it. I did a part of the routing and I don't know what I did, but now when I move a room, the components don't move with it.

I found something in the documentation:

Once component(s) have been assigned to a room, they move when the room is moved. To move a room without moving the components, temporarily disable the associated Room Definition rule - either in the PCB Rules and Constraints Editor dialog or in the PCB Inspector panel (with the room in question selected in the workspace).

But I wasn't successful with this help...

What should I do?

\$\endgroup\$

2 Answers 2

1
\$\begingroup\$

Rules->Placement->Room Definition->Make sure rooms are enabled.

\$\endgroup\$
0
\$\begingroup\$

Ok, after a clik on the menu "Design / Import changes", components move again with the room.

I don't know why.

\$\endgroup\$
2
  • 1
    \$\begingroup\$ You should add a little more detail into this answer if you want it to be helpful \$\endgroup\$
    – MCG
    Dec 5, 2018 at 14:44
  • 1
    \$\begingroup\$ I did my best.. \$\endgroup\$
    – Julien
    Dec 5, 2018 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.