1
\$\begingroup\$

I'm having trouble with the ir2110 output. I'm working on a class d full bridge amplifier and I use 2 ir2110 to drive 4 irf540N mosfets. The switching frequency I use to generate the PWM is 240kHz and I include a 100ns dead-time (ideally would be no more than 50ns), but still got some peak in the output that generates shoothrough. In the picture you can see the circuit, that includes a snubber, the filter and load. The 2VM voltage is 15V.

ir2110_circuit

The problem I need help with is that the deadtime is correct at the input of the ir2110, but in the output i get a peak (circled in red) which is causing the problem and I don't know what causes it. I tried with different values for the gate resistance of the MOS's, but when using a smaller value, 10ohms for example, the shootthrough is indeed smaller but not as small as I would like it to be, and the strange peak behaviour persists.

ir2110_input_output

I get this shootthrough current:

enter image description here

The MOS capacitance and charge characteristics are as follows

enter image description here

In real life, I made the PCB and I'm getting the exact same result as in the simulation.

Thanks in advance.

\$\endgroup\$
  • \$\begingroup\$ offhand I'd say your 47 ohm gate drive resistor value is a bit high, check your FET gate capacitance. Your driver may not be driving them as fast as you think (remember that one RC tau doesn't mean that the (dis)charge voltage is anywhere close to the (desired) new drive voltage (especially if your Vgs threshold voltages are low). \$\endgroup\$ – isdi Dec 5 '18 at 16:08
  • \$\begingroup\$ Thanks for your answer isdi, i forgot to mention that i tested it with many different values and, although in effect the shootthrough is smaller, this strange peak still appears. The datasheet doesn't give out the gate capacitance, I have the parasitic capacitances and gate charge (1700nC), I updated the post with this information. How would I calculate the capacitance in order to obtain the tau? \$\endgroup\$ – Rodrigo Dec 5 '18 at 16:39
  • \$\begingroup\$ Please draw your MOSFETs as proper symbols. \$\endgroup\$ – Andy aka Dec 5 '18 at 17:53
  • \$\begingroup\$ Do you have evidence of shoot-through? Do you have a trace of the current through the FETs? \$\endgroup\$ – Phil G Dec 5 '18 at 19:43
  • \$\begingroup\$ @PhilG I uploaded a picture with the current peaks through the FETs. \$\endgroup\$ – Rodrigo Dec 7 '18 at 16:31
1
\$\begingroup\$

The IR2110 is designed to supply +/-2A to drive the gate of your output devices.

You have an asymmetric drive caused by the 47 Ohm and diode across it.

You have not specified what 2VM1 is, but assuming it's no more than a 15V supply your maximum gate drive current is about 0.3A during turn on. During turn off you may be exceeding the gate drive capability of the IR2110 since you then have 47 Ohm with whatever the effective Vf slope resistance of the diode is (along with a 0.8-0.9V offset).

I'd suggest you could remove D2, 3, 5, 6 and replace the 47 Ohm with 10 Ohm resistors. This will make the turn on/off delays the same which is important. With a 15V VCC that will give you 1.5A charge/discharge current.

\$\endgroup\$
  • \$\begingroup\$ Sorry for not specifying the 2VM voltage, as you correctly supposed, it's 15V. With 10ohms the shoothrough is smaller, but the diodes are important to achieve a fast discharge, if I take them off, the shoothrough worsens a lot. \$\endgroup\$ – Rodrigo Dec 5 '18 at 17:12
  • \$\begingroup\$ The IR2110 has approximately even time delays through the high and low channels (90-120ns). You should really be setting up the deadtime in your Hin/LIN signals NOT at the gate of the device. \$\endgroup\$ – Jack Creasey Dec 5 '18 at 17:15
  • \$\begingroup\$ Also see Vishay AN608A for a very nice tech note on various techniques to calculate turn on/off transients. Is this circuit something that is already built or is this a simulation only? You may also be experiencing some channel modulation effects that could be extending the transient timing. \$\endgroup\$ – isdi Dec 5 '18 at 17:19
  • \$\begingroup\$ Jack, you're right aboute the delay, it's 130ns, the same in both HIGH and LOW channels, but the waveform isn't a perfect square wave, it's an exponential as you can see in the picture, thus needing the diode to improve the speed of the discharge. I'm not being stubborn about the diodes, I just see the results in simulation and real life, so I apologize if there's something I'm missing about your suggestion. \$\endgroup\$ – Rodrigo Dec 5 '18 at 17:24
  • \$\begingroup\$ @Rodrigo In the end it's up to you. From my perspective I'd be minimizing the delays driving the gate and fix Hin/Lin for deadtime. If you don't do this then you get different results with every external device you use since the gate capacitance varies device to device. Good luck. \$\endgroup\$ – Jack Creasey Dec 5 '18 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.