1
\$\begingroup\$

This is my first time using an ESP8266 WiFi module, and I'm having a lot of trouble just setting it up. My goal is to get the module to run a simple Arduino Blink sketch so that I could proceed to writing more complex code.

I'm using an ESP-01 module and this USB to Serial breakout board.

I then learned from this video tutorial that I had to make changes to the original breakout board so that the module could be programmed. These changes include soldering a connection between the CH_PD and VCC pins, and soldering a button between GPIO 0 and ground. The idea is that the button must be pressed when inserting the breakout board into the PC so the ESP enters programming mode; when released, the module can supposedly execute the uploaded code.

Here is the breakout board with the changes made:

enter image description here

Due to lack of buttons, my teammate and I crudely soldered jumper wires instead, connecting them together and disconnecting them to simulate pressing and releasing the button, respectively, as shown below:

enter image description here

enter image description here

In Arduino IDE, I have the board set up like so:

enter image description here

and I'm trying to upload and execute this sketch:

void setup() {

  pinMode(LED_BUILTIN, OUTPUT);

}

void loop() {

  digitalWrite(LED_BUILTIN, LOW);   
  delay(1000);                       
  digitalWrite(LED_BUILTIN, HIGH);    
  delay(2000);

}

The code is supposedly uploaded to the ESP as shown by the output below:

enter image description here

Regardless, the module doesn't seem to be executing it, nor any other example sketch I tried for that matter. The module would briefly flash blue when inserted in programming mode, and would flicker blue as the program is being flashed, but then nothing else happens on it.

Other notes:

  • When setting up the Arduino IDE, I downloaded the 2.5.0-2 beta ESp8266 platform.
  • I tried connecting the breakout board directly into the PC's port and to a USB extension to see if there was any difference, and there wasn't any.

What am I doing wrong here? If there is a better solution, what is it?

Thanks in advance!

\$\endgroup\$
  • \$\begingroup\$ I too was struggling to get it work. Always flashing successful but didn't work. This post helped resolve the issue by changing FlashMode to DOUT. Thank you very much \$\endgroup\$ – Karthikeyan Feb 3 at 2:25
1
\$\begingroup\$

Thankfully I got it to work by changing the "Flash Mode" setting in the "Tools" menu to "DOUT" and it seemed to have done the job. I'm not sure if this was relevant was well, but I also changed the ESP8266 built-in boards version to 2.4.0.

\$\endgroup\$
  • \$\begingroup\$ Good work. Note that it's better to paste the code into your question (using the {} formatting button) rather than a screengrab. That way we can copy and edit it in our answers. \$\endgroup\$ – Transistor Dec 27 '18 at 20:44
  • \$\begingroup\$ Thanks, and you're absolutely right. I'll keep that in mind for future posts if any; for this question, I used a screengrab as the code can be found in the Arduino IDE examples section. \$\endgroup\$ – gameCoder95 Dec 27 '18 at 21:19
  • 1
    \$\begingroup\$ No! It's the 2.4 that fixed your problem. I had exactly the same issue now :( DOUT and 2.4 It's not working with 2.5 \$\endgroup\$ – Adrian Andrei Apr 23 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.