1
\$\begingroup\$

I have several boards with SIM800C GSM module. One of them works correctly when I issue HTTP GET request (returns HTTP 200). All other boards returns HTTP 602 all the time. 602 stands for "No memory" according to manual. HTTP POST works fine on all boards.

[2018-12-29 00:43:30] <DEBUG><GSM >Sending to GSM:AT+HTTPINIT
[2018-12-29 00:43:30] <DEBUG><GSM >GSM returned 0
[2018-12-29 00:43:30] <DEBUG><GSM >Sending to GSM:AT+HTTPPARA="CID",1
[2018-12-29 00:43:30] <DEBUG><GSM >GSM returned 0
[2018-12-29 00:43:30] <DEBUG><GSM >Sending to GSM:AT+HTTPPARA="URL","http://37.19.1.5/firmware/new?serial_number=FF
[2018-12-29 00:43:30] <DEBUG><GSM >GSM returned 0
[2018-12-29 00:43:30] <DEBUG><GSM >Sending to GSM:AT+HTTPACTION=0
[2018-12-29 00:43:30] <DEBUG><GSM >GSM returned 0
[2018-12-29 00:43:33] <DEBUG><GSM >GSM returned +HTTPACTION: 0,602,0
[2018-12-29 00:43:33] <DEBUG><GSM >Sending to GSM:AT+HTTPTERM
[2018-12-29 00:43:33] <DEBUG><GSM >GSM returned 0

GSM module on the board that works fine was purchased via trusted local reseller. Buggy GSMs were bought on aliexpress. All boards have the same SW revision - 1418B08SIM800C24_BT.

Does anybody have any idea what can cause this issue?

\$\endgroup\$

1 Answer 1

0
\$\begingroup\$

This appeared to be an issue with my custom WEB server. WEB server was correctly handling GET request from first device only. For all other devices it returned 500 Server error with ~500kB of text response.

SIM800, apparently, was not able to process such huge response and returned "602 No memory".

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.