0
\$\begingroup\$

I have a follow-up question to this one.

enter image description here

I have a type C connector with 8 pins. No spec, type C female counterpart reveals G, Vcc, A2, A3, A6, A7. Remaining two pins do not respond to anything. G-Vcc shows 5.10V. A6-A7 shows 38 kOhm. G-A5/G-B5 on female counterpart shows 4.84V.

When using this to connect high-speed USB C device, system gives the following output:

[330114.311007] usb 3-2: new low-speed USB device number 61 using xhci_hcd
[330114.439054] usb 3-2: device descriptor read/64, error -71
[330114.675048] usb 3-2: device descriptor read/64, error -71
[330114.910996] usb 3-2: new low-speed USB device number 62 using xhci_hcd
[330115.039040] usb 3-2: device descriptor read/64, error -71
[330115.274963] usb 3-2: device descriptor read/64, error -71
[330115.382963] usb usb3-port2: attempt power cycle
[330116.034978] usb 3-2: new low-speed USB device number 63 using xhci_hcd
[330116.035567] usb 3-2: Device not responding to setup address.
[330116.243594] usb 3-2: Device not responding to setup address.

I'm new into this topic, and I've searched the available sources. Seems that the proper resistor is missing, but the problem is that I don't have an A5 pin! One of the tiny lanes on the plug itself does respond to A5, but why its pin is hidden by design? What could be done in this case?

\$\endgroup\$
  • \$\begingroup\$ USB is a transmission line and needs proper impedance matched cable. You seem to be using 4 plain bodge wires (?). That might be (part of) your problem. \$\endgroup\$ – Unimportant Dec 31 '18 at 7:54
  • \$\begingroup\$ @Unimportant I've re-soldered directly to the USB cable w/o bodge wires (see updated photo). Unfortunately, that made absolutely no difference. Any other ideas? Thanks! \$\endgroup\$ – Dmitry Mikushin Dec 31 '18 at 12:20
1
\$\begingroup\$

If you see the initial connect event as Low Speed while the device is actually a HS, it means that green and white wires are swapped. The plug should have A5 connected to ground via 5.1k resistor, it should be somewhere on the PCB interposer.

\$\endgroup\$
  • \$\begingroup\$ Awesome, many thanks, swap helped! Maybe together with @Unimportant's suggestion about wires, because I've tried to swap before. \$\endgroup\$ – Dmitry Mikushin Dec 31 '18 at 22:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.