0
\$\begingroup\$

I have a 8 channel, 10A SPDT relay, which I'm having problems getting to work. Here are its specifications. I've attached a few images below for reference.

  1. So, initially, I connected a 6V power supply to VCC and GND pins and supplied a 5V input signal to input 8. I checked the continuity with a DMM, and the Normally closed (NC) and Common (C) terminals are showing continuity before and after giving the control signal.

  2. Then, I increased the control voltage to 18 V, but there's still no switching sound and no continuity between normally open (NO) and common (C).

  3. I also tried increasing the the voltage to VCC to 12 V, still doesn't switch

  4. I tried jumping the two GND pins and repeated the procedure, still the same results

  5. Finally, I increased the VCC to 48 V and jumped the VCC and input 8 pins, the relay switched then. I heard the click and checked the continuity. But, the specs say that the control signal HIGH voltage is 2.5 V+. So why can I not get it to work at lower voltages?

  6. I thought the relay might be bad and repeated this process with another relay, but even that's not being energised for conditions 1 to 4. (I did not check condition 5 for it)

I think there's a mistake in my understanding of how to wire/power relays. Where am I going wrong?

Thanks a lot!

P.S.: I did try all the 8 channels on the relay, but with same results.

enter image description here enter image description here enter image description here

\$\endgroup\$
  • \$\begingroup\$ Are all of those transistors installed backwards? \$\endgroup\$ – Chris Knudsen Jan 17 at 21:34
  • \$\begingroup\$ What's printed on the transistors (part #)? \$\endgroup\$ – Chris Knudsen Jan 17 at 21:37
  • 1
    \$\begingroup\$ You bought 48V version. So it needs 48V nominal for the coil(for the control input). You need the version with lower nominal coil voltage, \$\endgroup\$ – atmnt Jan 17 at 21:43
  • \$\begingroup\$ Here is the 5V model aliexpress.com/item/… But you might still need buffer check the nominal current \$\endgroup\$ – atmnt Jan 17 at 21:45
  • \$\begingroup\$ It's worth pointing out that this is properly called a "relay module"; the little blue boxes on it are the relays themselves. \$\endgroup\$ – Hearth Jan 17 at 22:00
4
\$\begingroup\$

These are 48V coil relays.

You can drive the LED with 3~5V but the coil needs 48V on Vcc and Gnd.

Maybe you bought the wrong relays.

(not exactly as later found on website)

schematic

simulate this circuit – Schematic created using CircuitLab Above was my guess.

below is from website

8ch 48V coil boards

53831

enter image description here

Looks like I guessed wrong on the LED connection from your photo, but close enough on the driver level. Your link was for a different board. (24V)

So Vcc is 48V with common ground with driver = 3.3V to 5V

So yes it looks like your connections were incorrect, perhaps ground or one port transistor is damaged with significantly reduced hFE if the logic input threshold is now 29V instead of <3V

\$\endgroup\$
  • \$\begingroup\$ Hey! So if I use 48V on VCC and GND, and use a 5V for the control signal input, will that work as well? \$\endgroup\$ – Ved Soni Jan 17 at 22:49
  • \$\begingroup\$ @VedSoni - No, it won't work. 2N3904s are only rated for 40 volts. \$\endgroup\$ – WhatRoughBeast Jan 18 at 0:09
  • \$\begingroup\$ The transistors on my relay are 2N5551 \$\endgroup\$ – Ved Soni Jan 18 at 0:30
  • \$\begingroup\$ @VedSoni It should work fine. 2N5551s are rated for something like 140V, so you have plenty of margin. \$\endgroup\$ – Hearth Jan 18 at 0:34
  • \$\begingroup\$ This schematic is what I see from the part values on your photo and it works and agrees with my web searched specs. \$\endgroup\$ – Sunnyskyguy EE75 Jan 18 at 4:40
0
\$\begingroup\$

As per the circuit diagram you need to provide above 2.5V between control signal and ground and rated operated voltage as per the module number between Vcc and gnd. Please check the supply from which you are sourcing, some time it is set on a zero current and that is why not able to provide sufficient current.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.