-2
\$\begingroup\$

I have a Quartus Cyclone3 project with NIOS2 processor. I have noticed 3 errors while building the eclipse project, though I am pretty sure it should be working well.

Description: make[1]: [public.mk] Error 1
Resource: FW_SCT_SIM_NIOSII
Type: C/C++ Problem

Description: make: [public.mk] Error 1
Resource: FW_SCT_SIM_NIOSII_BSP
Type: C/C++ Problem

Description: make: [../FW_SCT_SIM_NIOSII_BSP/-recurs-make-lib] Error 2
Resource: FW_SCT_SIM_NIOSII
Type: C/C++ Problem

what are the reasons for the errors and how should I fix the problem? are they fatal, or I can leave them like that?

Console messages look like this:

**** Build of configuration Nios II for project FW_SIM_NIOSII_BSP ****

make all
0 [main] pwd 34688 find_fast_cwd: WARNING: Couldn't compute FAST_CWD pointer. Please report this problem to the public mailing list cygwin@cygwin.com

0 [main] sh 35264 find_fast_cwd: WARNING: Couldn't compute FAST_CWD pointer. Please report this problem to the public mailing list cygwin@cygwin.com

0 [main] echo 32640 find_fast_cwd: WARNING: Couldn't compute FAST_CWD pointer. Please report this problem to the public mailing list cygwin@cygwin.com
Makefile not up to date.

0 [main] echo 18444 find_fast_cwd: WARNING: Couldn't compute FAST_CWD pointer. Please report this problem to the public mailing list cygwin@cygwin.com
D:.../FW_SIM_NIOSII.sopcinfo has been modified since the BSP was generated.

0 [main] echo 26440 find_fast_cwd: WARNING: Couldn't compute FAST_CWD pointer. Please report this problem to the public mailing list cygwin@cygwin.com
Generate the BSP to update the Makefile, and then build again.

0 [main] echo 44376 find_fast_cwd: WARNING: Couldn't compute FAST_CWD pointer. Please report this problem to the public mailing list cygwin@cygwin.com

0 [main] echo 28532 find_fast_cwd: WARNING: Couldn't compute FAST_CWD pointer. Please report this problem to the public mailing list cygwin@cygwin.com
...
and so on (a lot of mess)

make: *** [public.mk] Error 1

\$\endgroup\$

closed as unclear what you're asking by Eugene Sh., RoyC, Dwayne Reid, Finbarr, Elliot Alderson Jan 24 at 13:48

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    \$\begingroup\$ Look in the console output for more details. The info you posted has no context. \$\endgroup\$ – Tom Carpenter Jan 18 at 13:42
  • \$\begingroup\$ Nowhere near enough information. Suggest that you strip your project down to the bare minimum and then keep adding to it until it won't build. Then modify your question with what you have learned. \$\endgroup\$ – Dwayne Reid Jan 20 at 5:58
  • \$\begingroup\$ Here is what console looks like (added) \$\endgroup\$ – RKishmar Jan 21 at 5:10
0
\$\begingroup\$

Ok, so I did this and that and finally found the cure.
Project RBM click -> Index -> Freshen all files
and
Project RBM click -> Index -> Rebuild
That's how I got rid of those errors. But I did get much more new ones. They look like this: Type 'alt_u32' could not be resolved line 28 Semantic Error
So I tried a few things and got rid of them by going
Project RBM click -> Source -> Format
This removes the errors.
But I'm still curios about how and why did this happen.

\$\endgroup\$
  • 2
    \$\begingroup\$ If you get the unresolved errors, you either haven't included the files where they are defined, system.h in your case, or the IDE hasn't updated it's indexer. Source-Format doesn't do anything with your "could net be resolved" error. It just reformats the text, but it could be that the index was refreshed after the file content changed because of the formatting. Also I get this error a lot, when i create a new project and import the source files. Often creating a dependency in the project settings to the BSP helps. \$\endgroup\$ – Eggi Jan 23 at 11:41
  • \$\begingroup\$ some how only "Source-Format" helps. so I see it's because of problems with links to or dependecies that have full paths as parameters. how can I fix this? \$\endgroup\$ – RKishmar Jan 28 at 9:21
  • \$\begingroup\$ Just don't make static links. What do you do if you store the project in a repo and another one checks out? You would have to keep the same order structure on every pc that's involved in the project. If you have such a problem i would recommend creating a new project and keep dynamic links. Editing the makefile to change your static links is an error source. \$\endgroup\$ – Eggi Jan 31 at 8:22
  • \$\begingroup\$ I know that. I have a project that was built this incorrect way and i have to use it somehow. \$\endgroup\$ – RKishmar Jan 31 at 13:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.