-1
\$\begingroup\$

This question already has an answer here:

I've bought 2 ATtiny's from AliExpress and I can't program them. I've read some feedback and people say that they might be fake but then I saw some activity on IO pins. So I've made a small oscilloscope program on my Arduino:

On pin 2 there was a square wave signal and on pin 7 there was a signal, fading in and out.

my question is that the microcontroller is original or not and also I want to know how can I unlock the MCU, if it's locked?

Sorry if my English is bad.

When I try to program it it says avrdude: Yikes! Invalid device signature. Double check connections and try again, or use -F to override this check. I used Arduino as IDE. The error shows up in ArduinoIDE.

schematic

simulate this circuit – Schematic created using CircuitLab

There's a 10uF capacitor between Arduino's reset and Ground

Here's a photo of the chip (Sorry for low quality my phone didn't want to focus) Chip

\$\endgroup\$

marked as duplicate by Chris Stratton, Elliot Alderson, Finbarr, Edgar Brown, Sparky256 Jan 26 at 4:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • \$\begingroup\$ insufficient information \$\endgroup\$ – Sunnyskyguy EE75 Jan 23 at 16:38
  • 4
    \$\begingroup\$ Take a photo of the chip. We can often tell if it's a fake. \$\endgroup\$ – Janka Jan 23 at 16:55
  • 1
    \$\begingroup\$ If they are ATtinys they seem to be preprogrammed, you may need a high voltage programmer to get them back to a normal ISP mode. Perhaps not worth it for $2 of mystery chips. \$\endgroup\$ – Chris Stratton Jan 23 at 17:07
  • 4
    \$\begingroup\$ Sorry, but we have to be able to read the markings. \$\endgroup\$ – Janka Jan 24 at 10:16
  • 1
    \$\begingroup\$ "I've bought ... from AliExpress and I can't ..." - Throw them away, or claim a refund. And next time, try buying somewhere a little more reputable. When ordering the cheapest stuff you can find straight from China, it's always a gamble. Looks like this time, you lost. \$\endgroup\$ – marcelm Jan 24 at 20:46
1
\$\begingroup\$

Do you change board settings on Arduino IDE. You should select ATtiny as a board from tools menu. if there isn't ATtiny board in your ide you can add it by using board manager. For this

  1. Open File -> Preferences and in the Additional Boards Manager URLs give this url https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-manager/package_damellis_attiny_index.json.
  2. Tools -> Board -> Board Manager
  3. Write attiny (by Davis A. Mellis) in searchbox and install it

After then you can select ATtiny board from ides board menu. For ATtiny 85 you change folowing settings from tools menu.

  1. Select Processor as ATtiny 85
  2. Select Clock 8MHz internal
  3. Select Programmer Arduino as ISP
  4. Select Burn Bootloader

After you do this 4 changes you can upload your code to ATtiny85.

\$\endgroup\$
  • \$\begingroup\$ Did that and it still shows the same error. \$\endgroup\$ – patryk3211 Jan 24 at 13:57
0
\$\begingroup\$
  • What Arduino are you using to program with?
  • Did you first upload the ArduinoISP sketch to the programming Arduino? Make sure you upload this sketch (from the example sketches) before you attach the capacitor. After the IDE has finished uploaded, then attach the 10uF capacitor, and change all your IDE settings for the ATtiny and try to upload.
  • Do you have "Arduino as ISP" selected under the programming menu? (not to be confused with ArduinoISP).
  • Are you certain the ATtiny is receiving 5V on pin 8 and GND on pin 4? That error also shows up if the ATtiny isn't powered properly.

The 10K pullup resistor isn't absolutely necessary.

\$\endgroup\$
  • \$\begingroup\$ I've did everything you said and it still doesn't work. I'm sure that everything is connected properly because I've replaced attiny85 with attiny13 and it programmed correctly. \$\endgroup\$ – patryk3211 Jan 25 at 13:10
  • \$\begingroup\$ Definitely crap from Alibaba. You can purchase them from websistes like Digikey, Mouser, and reputable sellers on eBay. I personally have bought around 100+ ATtiny's for personal projects and work projects from G&C supermarket on eBay, and I've never had and issue with them. ebay.com/itm/… \$\endgroup\$ – HavocRC Jan 25 at 18:20
  • \$\begingroup\$ Did you place a capacitor between the Arduino Uno's Reset and GND Pins? \$\endgroup\$ – Tjaart van aswegen May 16 at 13:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.