0
\$\begingroup\$

I'm creating a board that has a ACS712 as current sensor. This little CI has two pins that actually has the same function and are linked internally. What I'm trying to do is link this two pins in the same route using EAGLE as the image below.

enter image description here

Does anyone know if there is some feature to do this in EAGLE?

\$\endgroup\$
  • 1
    \$\begingroup\$ Are they connected by a net in your schematic? Also for those particular pins you'll probably want to make the connection via a polygon pour (assigned to the appropriate net), not a trace. And if you can manually hot air solder it, perhaps make the pour with no thermal relief. \$\endgroup\$ – Chris Stratton Jan 23 at 17:33
  • \$\begingroup\$ @ChrisStratton, yes, they are connected by a net. I'm trying to make the polygon works and if so I'll return back. \$\endgroup\$ – Athus Vieira Jan 23 at 17:58
  • \$\begingroup\$ @ChrisStratton the polygon button did not work! It's making a shor circuit with the ground plane even they have different names. The settings that I'm using for the polygon are: Solid, Thermal Off, Drop Orphans \$\endgroup\$ – Athus Vieira Jan 23 at 18:10
  • 1
    \$\begingroup\$ Set your non-ground polygon's rank to a different value and set an isolate setting (I forget if on one or both, change in licensing model basically killed interest in it). There's probably an existing question on multiple pours in eagle which this is a duplicate of. \$\endgroup\$ – Chris Stratton Jan 23 at 18:13
  • 1
    \$\begingroup\$ Changing the rank worked! I changed the rank of the ground plane to 2 and the non-ground polygon to 1. If you want, post this as a solution and I'll accept it as an answer. Thank you again @ChrisStratton \$\endgroup\$ – Athus Vieira Jan 23 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.