0
\$\begingroup\$

I am making a simple BCD to 7 segment decoder but for some weird reason, the ICs I am using, 7432 and 7408 are not working properly.

My 7408 ICs (all 5 of them) are always producing high outputs, regardless of the inputs. While my 7432 ICs (again, all 5 of them) are acting like AND gates, i.e. only producing high output when both inputs are also high. I am using a 9V battery to power the circuit. Pin 14 of the ICs are connected to positive and pin 7 are to connected to negative.

Are my ICs broken or have I done something wrong in my circuit that I failed to notice?

\$\endgroup\$
  • 3
    \$\begingroup\$ can you please edit the question and add schematic \$\endgroup\$ – Satish Singupuram Jan 26 at 10:46
  • \$\begingroup\$ It is unlikely that all of your ICs started out bad. It is possible, though, that an improperly designed (built) circuit could destroy every IC you plug in. It is also possible that your circuit is wrong and that the ICs are OK. \$\endgroup\$ – JRE Jan 26 at 11:24
  • 1
    \$\begingroup\$ @HandyHowie yes i have used ICs already for creating simple circuits, e.g., multiplexer and full adder. I am using a 9V battery and I connected the positive to pin 14 and negative to pin 7 of the ICs. \$\endgroup\$ – user75283 Jan 26 at 11:47
  • 4
    \$\begingroup\$ A 9V battery wil instantly destroy a genuine 74 series IC. Operate them from the correct supply voltage. \$\endgroup\$ – Brian Drummond Jan 26 at 12:09
  • 1
    \$\begingroup\$ Your question would be much better with all the context added: how you are powering them, how you've mounted them, a schematic diagram, and a decent high resolution picture of your set-up. \$\endgroup\$ – james Jan 26 at 12:10
4
\$\begingroup\$

74 series ICs need a 5V supply. For the original 74 series logic, the typical absolute maximum VCC voltage is 7V, above that you kill the chips.

If you want to experiment with discrete logic and use 9V power, 4000 series logic is the simplest. Use a 4081 for the AND gate and a 4071 for the OR gate.

Unlike the 7400 series the 4000 series logic works from 3V to 18V, however unlike the 7400 series chip you need to connect all unused inputs to something.

\$\endgroup\$
  • \$\begingroup\$ But for normal operation, the supply voltage should not be above 5.5 V. \$\endgroup\$ – Uwe Jan 26 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.