0
\$\begingroup\$

I am developing a new board that uses an STM32F427 MCU and the LAN8720A as an ethernet PHY.

This is my first design with this MCU, but I've done multiple designs with this PHY and other MCUs. I never had any similar issue before.

Here is the LAN8720A schematic: LAN8720A schematic

The RESET line is connected to the LAN8720A reset pin, to the STM32F427 reset pin and to a user button.

During the initial power-up of the PHY, it operates normally. The MCU is able to read and write its registers through the MIIM bus.

When I press the reset button, the LAN8720A somehow crashes. It is not responding to the MCU any more, and LED1 is blinking randomly.

I checked extensivelly the datasheet of the PHY regarding its power-up and reset requirements, and as I can say I do not violate any of these conditions.

I have tried in 3-4 different boards, triple checked everything, with PHY chips from 3 different vendors (so any manufacturing issue, or any defective batch of chips I think is ruled out).

I also tried to add an RC circuit to the RESET line. When I got to 10k / 10uF the chip crashes also during power up (which contradicts what the datasheet says. It states a minimum reset delay requirement, not a maximum one).

What might be the cause for this problematic behavior of this chip?

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.