0
\$\begingroup\$

I've designed a PCB which contains FT2232H for UART and SWD debugging for a microcontroller in the PCB (STM32L0). The FT2232H circuit looks like this:

enter image description here

and the power schematic that contains the USB micro connector looks like this: enter image description here

When I connecting the board to the USB port in my PC all the 3 LEDs (D3, D4, D5) are light up, it means that the power rails are OK (VBUS - 5V, 3.3, 3V) but, then I don't see any message from windows about new USB device detection. nothing happens. the system doesn't detect device insertion or removal. I have designed the FT2232H circuit above according to the datasheet(page 69 Bus-Powered Configuration), and this reference design

Do you have any suggestions on how to debug or to solve my problem?

Thank you very much!

\$\endgroup\$
  • \$\begingroup\$ at first glance I am not seeing anything anomalous... Have you verified that the UART is configured properly on the STM32? \$\endgroup\$ – Luke Gary Feb 5 at 17:55
  • \$\begingroup\$ @LukeGary I don't know if the UART is configured properly because the Windows doesn't show any USB device connection or recognize the FT2232H. It seems like it's dead. nothing happens when I connect my PCB to my PC. system doesn't detect device insertion or removal. \$\endgroup\$ – Mercury Avangburg Feb 5 at 18:22
  • \$\begingroup\$ Inspect the connections under magnification. Probe the USB and see if you see evidence of the detect pull-up. \$\endgroup\$ – Chris Stratton Feb 6 at 0:58
  • \$\begingroup\$ @ChrisStratton what do you mean by detect pull-up? \$\endgroup\$ – Mercury Avangburg Feb 6 at 17:20
  • 1
    \$\begingroup\$ USB devices must pull up either D+ or D- for initial detection by the host as a full or low speed device (high speed devices detect as full speed then extend to high by signaling). Even just a resistor on the USB port is enough to get some kind of unknown or failed device message from the OS at least in logs somewhere. You may want to check out the chips 1v8 rail and see if its clock is running, too. And make sure the chip is on the board in the right orientation. \$\endgroup\$ – Chris Stratton Feb 6 at 18:11
1
\$\begingroup\$

Then I comparing your design to the mines (which are working fine) the only obvious difference are the resistors R20 and R21 you put into the D+ and D- line and that you do not have transient filters in the data lines. I use there a VBUS053CZ but this should not affect the behavior of your board and the resistors might not play a big roll either as they are used in the mini module as well. If you have not solved the problem already I would recommend to probe if the supply voltages have the right values (e.g. the 1.8V from the internal regulator and the voltages at teh VPLL and VPHY pins) and if the crystal is starting up correctly (probe with an scope OSCI and OSCO and check if you see a stable frequency of 12 MHz). Are the components (especially filters etc) close to the related pins?

Else sometimes building up a second board helps to figure out if it is a connection/assembly or systematic problem.

\$\endgroup\$
  • \$\begingroup\$ The problem solved. VPHY wasn't connected to the power supply. \$\endgroup\$ – Mercury Avangburg Apr 26 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.