I have several Altium schematics, with a harness going through several level of sheet symbols and ports. This harness contain another harness, along with a few normal nets.

The signals of that sub-harness are not properly connected.

So far, here are the symptoms:

  1. Harness definitions match, there no harness definition errors.
  2. The ports name and the sheet entries matches properly.
  3. The ports and sheet entries harness type are identical.
  4. The Design>Synchronize Sheet Entries and Port menu return "All Sheet symbols are matched"
  5. There are no errors when I compile the project, except that the net that should be connected together contain only one pin.
  6. After I compile and until I change something on the port or the entries, they show an error in the schematic editor, "Port not linked to parent sheet symbol" or "Sheet Entry not linked to child sheet"
  7. Both the top harness and the sub-harness shows the errors of 6, but the pins are properly connected on the top harness.

I cannot share my documents, but I can post some small extracts. Let me know if you need more details.

What should be my next step to debug this issue?

Edit: This is a version of the project with only the problematic harness.

Edit 2: I could not make it work with connector-free harnesses, I don't know how to set a type for the sub-harness without the connector. To continue my project I uses a single level for the harness but I still want to know what the problem was...

  • \$\begingroup\$ You should certainly post some images :-) \$\endgroup\$ – Tom L. Feb 7 '19 at 10:28
  • 1
    \$\begingroup\$ Make a copy of your project, strip out everything but the harnesses. Make sure it still breaks. Share or post the result. \$\endgroup\$ – Chris Knudsen Feb 7 '19 at 13:25
  • \$\begingroup\$ @ChrisKnudsen I added the project to the question. It still break, hopefully not in a new way... \$\endgroup\$ – pserra Feb 7 '19 at 21:50
  • 1
    \$\begingroup\$ I took a look at your example project with AD19, and I could not get it to work either. I can't say that I've tried to nest harnesses before. Perhaps others will have better luck. Also this: https://electronics.stackexchange.com/a/414863/140087 \$\endgroup\$ – Chris Knudsen Feb 8 '19 at 19:43
  • \$\begingroup\$ @ChrisKnudsen Thanks for trying. I tried naming the harnesses, but that did not help. I think the next step is to try connector free harness and see what append. <rant> It's sad that Altium have so much trouble with buses and harnesses. Allowing net aliases could have made the thing so useful for readability. </rant> \$\endgroup\$ – pserra Feb 8 '19 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.