0
\$\begingroup\$

I am having an issue with a limit switch to turn on and off a circuit. I am using a L7805 5V regulator with a regular 9V battery as the power supply for my circuit. When I plug in the 9V battery normally, the circuit functions fine, however, if I add a limit switch/microswitch to turn on and off the circuit, the circuit does not function. I've tested countless things to no avail:

  • Different limit switches with different current ratings ranging from 2A to 5A and 50V to 250V AC or DC
  • Confirmed that the limit switches work properly when pressed using the multimeter's the continuity function
  • Made sure that the circuit works fine when I plug in the 9V normally by hand into the 5V regulators
  • Switched the breadboards that the circuit is currently onto different breadboards
  • Edit: Forgot to include that I've tried putting the limit switch in different places, I tried putting it between the 5V regulator and the 9V battery directly, and the 9V battery's ground and the 5V regulator's ground. Both do not seem to work either

I'm very confused at this point because the limit switches seem to function fine, and the circuit also functions fine without the limit switch. I did a search already and didn't find something similar to my issue, so apologies if this has already been asked. Any possible ideas/or even remote pointers would be much appreciated because I'm still new to electronics. A schematic of my circuit is also attached below in case it helps, its purpose is to drive a servo for a specific amount of time. Much thanks!

Picture of my Circuit

\$\endgroup\$
  • \$\begingroup\$ Are you aware that your 555/TIP120 is not going to provide anything close to 5 volts to your servo? You don't say what current you expect to provide, so I can't give an exact number, but II suggest you measure at the servo and see what you get. \$\endgroup\$ – WhatRoughBeast Feb 9 at 5:56
  • \$\begingroup\$ Oh I forgot to update it in the schematic, but yes I was aware, so I hooked up the power input of the servo to the 9V instead. Now there's approximately a 4.6V input on the servo. There's almost definitely a better way to power the servos, but the TIP's are all I have at the moment. \$\endgroup\$ – aaaaaaaaaachu Feb 9 at 6:10
  • \$\begingroup\$ Try increasing C8 as well as C9 to 3*100nF or 1*330nF (1 component is better). Make sure each bypass capacitor is very close to its L7805. \$\endgroup\$ – Huisman Feb 9 at 11:38
  • \$\begingroup\$ You need to provide a number of clarifications. (1) What drives the limit switch? (2) You need to give detail of what you mean when you say "the circuit does not work". (3) Why are you just switching the 5V to just the left 555 chip? \$\endgroup\$ – Michael Karas Feb 9 at 11:40
  • \$\begingroup\$ A 9V battery is in any case a poor choice for powering servos. Throwing away nearly half the energy by using a linear regulator won't help, either. \$\endgroup\$ – JRE Feb 9 at 11:57
1
\$\begingroup\$

Your limit switch is normally open, and closes when the limit is reached.

I expect you want to have your circuit powered when the servo is in the middle of the range, and un-powered when it reaches the limit, your switch does the exact opposite powering the circuit only when you're at the limit.

To do this you need a normally closed limit switch (or a limit switch which has both sorts of contacts).

\$\endgroup\$
  • \$\begingroup\$ I should have explained more clearly in my question, but my circuit's purpose is to have the servo move for a few seconds once the limit switch is closed, after which the servo stops until I reopen and close the limit switch. It functions fine when I connect the power source manually (acting as if I'm closing the switch), but oddly it doesn't seem to work with the limit switch. Hopefully that made sense. \$\endgroup\$ – aaaaaaaaaachu Feb 13 at 3:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.