0
\$\begingroup\$

A few days ago, I received my Anet A8 Power supply (240W, 20A) power supply in the mail. After the second time plugging it in, it blew the fuse and the rectifier.

I found a blob of solder connected to one of the pins where I connected my wires. Is this normal? I don't think that blob should be connected to that pin at all!

photo of solder side of PCB

The three big pins in the top left connect to this: enter image description here

This picture shows the burn marks on my rectifier: enter image description here enter image description here

This picture shows how the bottom pins are connected: enter image description here Thanks in advance.

\$\endgroup\$
  • \$\begingroup\$ Do you have any kind of schematic for the board? Can you tell from the layout if either the large net or the small pin attached to the large net by the blob is either power or ground? Do you have a multi-meter? \$\endgroup\$ – scuba Feb 11 at 22:10
  • \$\begingroup\$ i do have a multi-meter. what steps should i take? \$\endgroup\$ – wessel dijkstra Feb 11 at 22:14
  • 1
    \$\begingroup\$ The big three pins on the top left of your image. What do they attach to?Specifically the middle pin which is connected to the large net in your picture. And the pins on the bottom, are they all connected together? Another question, do you have any soldering tools. \$\endgroup\$ – scuba Feb 11 at 22:15
  • \$\begingroup\$ @scuba i updated my post with a picture of the part. I do have soldering tools, but my board is pretty much dead i think. There are burn marks on it. The pins on the bottom are not connected together. \$\endgroup\$ – wessel dijkstra Feb 11 at 22:20
  • \$\begingroup\$ You're not first and not the last who had buy a cheapo SMPS from "reputable" web site and it had blown. I suggest you to buy another one, don't spend time on repairing this (and similar) one because it'll blow anyway. \$\endgroup\$ – Marko Buršič Feb 11 at 22:43
0
\$\begingroup\$

It looks like it passed final test but then the excess lead length was sufficient to be bent over in transit to short out the gate or base to the wrong voltage and result in a short circuit to everything in its path towards the fuse. Just replace the burnt parts and hope for the best or do an inspection that the factory forgot to do with a QC stamp, ( next time).

the solder blob can help with surge power sink on startup, but it was the bent pin that was the culprit.

A solder sucker or lots of braid wire can soak up the solder with sufficient heat from 75W or more to allow cleaning the holes after cutting off the part and removing the pins with tweezers while molten. Don’t get too hot to burn the board.

\$\endgroup\$

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.