0
\$\begingroup\$

I have a pre-amp with a controller circuit which controls input signal micro-relays and a power supply relay. While the input signal micro-relays work normally, all of a sudden the 30 second delay for the power supply relay stopped working, in other words, the power supply relay connects as soon as I hit the power switch, without any delay. The unit worked perfectly for a long time. It was recently re-capped and worked normally for a while. Attached is the circuit schematic. Any help would be more than appreciated.enter image description here

\$\endgroup\$
  • 1
    \$\begingroup\$ I don't see any relays on that schematic. \$\endgroup\$ – Peter Bennett Feb 19 at 2:16
  • \$\begingroup\$ Is relay G the power control device? also, 30 seconds seems like a loooong power delay ... ? \$\endgroup\$ – AnalogKid Feb 19 at 2:44
  • 1
    \$\begingroup\$ @Tom, I think you need to add a credit to Elektor for that circuit schematic as per site policy. A reference to the magazine issue and article title would be useful too. \$\endgroup\$ – Transistor Feb 26 at 16:37
  • \$\begingroup\$ Yes, definitely, I am sorry. I built this unit according to their design from their March 1987 release. \$\endgroup\$ – Tom Mar 4 at 2:05
2
\$\begingroup\$

R110 and C113 form a power-on reset. You can scope N125 pins 8 and 10 to confirm that IC112 is being initialized correctly. Next, scope IC112 pins 9 and 7 to see if there are square waves there. If all of that is ok, the problem probably is N117, the relay driver.

I've done a version of this circuit many times. After reset, the CD4060 counts up until a particular pin goes high. That pin is connected through a diode to the 4060's oscillator, causing it to freeze. In this case, the 4060 waits for 512 counts after reset, which calculates out to something under 37 seconds. Then pin 15 goes high, which freezes the counter and energizes relay G. If G is on immediately, then:

a) G's contacts are welded closed. b) G's driver has failed short. c) the 4060 output is stuck high for some reason.

\$\endgroup\$
  • \$\begingroup\$ Thank you very much for your reply. It was the 4060. I replaced it and all goes back to normal with that module. \$\endgroup\$ – Tom Mar 4 at 2:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.