0
\$\begingroup\$

I have three different sets of chips, the attiny85, 328p, 328p-au. Initially, the avrisp mkii, was programming the atmega328p, however now it is not recognizing this chip (i.e. 328p) or the 328p-au.

I checked the circuit and everything seems fine, I added the necessary capacitor, and pull-up resistors. I am using atmel studio 7, and it is recognizing the attiny85, chips.

Since it was working initially, could this mean that maybe a setting on atmel studio might have a problem? Have anyone faced this interesting situation before?

Error:

Failed to enter programming mode. IspEnterProgMode:Error status received:Got 
0xc0, expected 0x00 (command has failed to execute on the tool)
\$\endgroup\$
  • 1
    \$\begingroup\$ A common issue is forgetting to connect the supply of the board to the ISP header. It is not there to power the board but to detect the I/O voltage. \$\endgroup\$ – Wesley Lee Feb 27 at 17:42
  • 2
    \$\begingroup\$ There is not really enough information here to make this answerable. If it does not work with new chips chances are something is wrong with your setup. If low voltage serial programming does not work with used chips you may have changed the fuse which disables the reset pin required for that, the one which requires an external clock, etc. And it is not clear what error message you are getting - for example, is no target detected or does it find the wrong ID code? Mixing up the ATmega328 vs the more common ATmega328p is common, they are similar but have different ID codes... \$\endgroup\$ – Chris Stratton Feb 27 at 17:43
  • \$\begingroup\$ I understand, I did connect all the grounds, as well as board supply to all vcc, did the same for the 328pu chip also. The voltage was showing at the pins, I'm really perplexed, because it is working for the attiny85. Do you think my programmer might be damaged? \$\endgroup\$ – tech_ninja Feb 27 at 17:46
  • \$\begingroup\$ Unlikely if it still works with 85's. You seem to have ignored a lot of what was said about things that need consideration. \$\endgroup\$ – Chris Stratton Feb 27 at 18:30
  • \$\begingroup\$ I'm sorry, I'm using a mobile app, and did not see your previous comment @Chris, however, they are new chips, no fuses have been changed as yet. They have the pre programmed internal rc oscillator selected by default. I tried this with multiple atmega328p chips, and selected the correct chip in avr studio. I also reduced the isp frequency, to no avail \$\endgroup\$ – tech_ninja Feb 27 at 18:48
0
\$\begingroup\$

I had the very same problem and I'm certain it wasn't my PCB. There was two things I seen that could have been at play for me,

  1. I was using a cheap USB extension cable between the computer and Avrmkii and I got the same errors as above. I switched to a better cable that I had and it started working...not sure if that was a solution but it seemed to work.
  2. I bought a new Avrmkii On Amazon because I ran into this error again some time later. It was on a different PCB that I made and when I plugged my old programmer into it I received the error but didn’t with the new one. However the mystery to me is that when I use the Old programmer with a standard 328 dip on a breadboard it still works. Hope you resolve your issues, post the solution if you find one.
\$\endgroup\$
  • \$\begingroup\$ This is more of an "I had that problem too" than an answer - to the degree that you provide a solution it amounts to little more than "I rolled the dice again with different parts" \$\endgroup\$ – Chris Stratton Mar 5 at 16:21
  • \$\begingroup\$ I agree with what you said, however if a faulty cable apparently solved my problem in one instance and a new programmer in another. I thought it was worth mentioning! If it helps than great, but if not then the problem still exists. \$\endgroup\$ – JAS823 Mar 5 at 16:25
  • \$\begingroup\$ well it turns out that it might have been a cable issue. I was using a 10 pin cable and that did not work. I then went to a 6 pin cable in which it converts a 10 pin to a 6 pin, and used the 6 pin header and that seemed to work fine. Thanks to everyone for their suggestion, and I hope your comments help others, as there are a number of things that can go wrong!! \$\endgroup\$ – tech_ninja May 31 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.