1
\$\begingroup\$

In our automated design due to MOSFET obsolete we have changed new MOSFET which gives us rise and fall time issue at the frequency applied from 10Khz to 500Khz. when we use the power MOSFET as Load and working in MOSFET active/Linear region of operation in our Dynamic load pattern test notifying this issue. Old Mosfet P/N: sie844df New Mosfet P/N: sie882df What are the parameters we have to look in to it to fine tune the circuit? appreciate all your help in advance.

enter image description here enter image description here

\$\endgroup\$
  • 1
    \$\begingroup\$ The gate charge of the new one is 3x-4x that of the old one so it's rise times are probably that 3x-4x longer. But it sounds like you aren't using these as power switches? You're using them in the linear mode? \$\endgroup\$ – Toor Feb 28 at 6:22
  • \$\begingroup\$ As Toor says. However not only is the gate charge 4x, the ID is 4x, and the RON is 1/4. The new one is like 4 of the old ones in parallel! \$\endgroup\$ – Neil_UK Feb 28 at 6:26
  • \$\begingroup\$ @Toor - Yes we are operating in a Linear mode \$\endgroup\$ – ramesh6663 Feb 28 at 6:28
  • \$\begingroup\$ new mosfet has higher Ciss than the old one like said X4 times, we are using op-amp LT1809 part to drive this Power MOSFET in linear mode \$\endgroup\$ – ramesh6663 Feb 28 at 6:30
  • \$\begingroup\$ The transconductance might also be affecting things. It's different by two. These are really different MOSFETs. \$\endgroup\$ – Toor Feb 28 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.