14
\$\begingroup\$

I've been to a couple introductory Altium trainings and everything goes fine and dandy. This is the actual first board I am working on by myself. I've been learning so much just by doing stuff myself but there is something that I can't seem to quite understand.

Whenever I transfer my schematic to the PCB is is placed inside this reddish box, I believe it is a Room. All the examples I saw during training didn't do this. And if I move the components outside the box they turn green (DRC error maybe?)

Does anyone know what this means?

http://i.imgur.com/wtxbh.png

\$\endgroup\$
  • \$\begingroup\$ That's called a room. It probably came from schematic. You can uncheck the room export at the time you synchronize. \$\endgroup\$ – Bryce Jun 17 '16 at 16:15
  • \$\begingroup\$ I hate, hate, hate rooms, every once in a while they keep creeping back into my designs \$\endgroup\$ – Voltage Spike Jun 10 at 21:00
21
\$\begingroup\$

That is indeed called a "Room".

Rooms are relevant if you're doing multi-channel design, as they let you copy the layout between channels.

It's also completely normal.

If you want to disable it, it's very easy to do:

  • Click the room -> PCB Inspector panel -> uncheck "Rule Enabled" checkbox.
    enter image description here
  • "Design" menu -> "Rules" menu item -> In the tree: "Design Rules" -> "Placement" -> "Room Definition" -> uncheck all the "Enabled" checkboxes.
    enter image description here

Alternatively, you can just delete the room, but it will come back next time you synchronize the schematic to the PCB.

\$\endgroup\$
  • 2
    \$\begingroup\$ In Project Options (somewhere, can't remember right now), you can disable rooms for the project so they won't come back. \$\endgroup\$ – dext0rb Oct 2 '12 at 1:14
  • 4
    \$\begingroup\$ @dext0rb - Hmm. I hadn't noticed that. You're right! It's Project options -> Class Generation -> "Generate rooms" \$\endgroup\$ – Connor Wolf Oct 2 '12 at 1:17
  • \$\begingroup\$ Or Project options -> Comparator -> Extra Room Definitions -> Ignore \$\endgroup\$ – Keegan Jay May 24 '16 at 22:19
31
\$\begingroup\$

No, this is the correct way to disable Rooms in Altium.

Go to Project -> Project Options

Altium Project Options Class Generation Rooms

In the class generation tab, you can select not to generate rooms. If your project contains multiple schematics, then you'll need to untick this box for each schematic.

\$\endgroup\$
  • \$\begingroup\$ This should be the accepted answer; it's very straightforward. \$\endgroup\$ – DavidEGrayson Oct 26 '15 at 23:59
  • \$\begingroup\$ How do I find and delete all existing rooms? \$\endgroup\$ – Bryce Jun 21 '17 at 6:13
  • \$\begingroup\$ @Bryce - To delete a room, click on it, and press delete. Do this for each of the rooms. \$\endgroup\$ – Rocketmagnet Jun 21 '17 at 9:43
  • \$\begingroup\$ That's assuming one can find the rooms. @Rocketmagnet \$\endgroup\$ – Bryce Jun 28 '17 at 8:47
3
\$\begingroup\$

Rooms are used for grouping components into logical areas. When working on complex projects, using rooms can make layout easier because components on a sheet of the schematic get placed into a room. This helps to make placement easier because you don't need to go hunting for all the components that you need.

Rooms are also used for multi-channel design, which allows you to design a circuit once and then instantiate multiple copies of the same circuit, including copying room layout.

\$\endgroup\$
0
\$\begingroup\$

I just delete the Rooms.

They have a pretty limited functionality, and are generally more trouble than they are worth.

\$\endgroup\$
  • \$\begingroup\$ Can you expand this answer a bit? \$\endgroup\$ – Kortuk Oct 3 '13 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.