0
\$\begingroup\$

I have a brushed motor and an ESC for brushed motors Motor rating is 12V 3A. ESC is the mod in the title. I have tried so much, but couldn't find a clue to find a relation between the led blinking, and how to speed up, change direction of the motor with the esc. I searched internet and also on the data sheet but couldnt finx a way out. Please help me? I have access to a function generator, if that helps. Thank you.

\$\endgroup\$
1
\$\begingroup\$

The slow red blinking is the voltage protection. https://static.rcgroups.net/forums/attachments/5/9/5/6/0/2/a7824090-71-ESC.png

I tried to hook it up to a 18V Li-Ion Battery Pack from a Drill and had the same problem, unfortunately it got not only a untervoltage, instead it got some overvoltage protection too. The BEC that delivers 5V is from the volatgeprotection unrelated, so servos are still working.

After i hooked it up to a 2s Lipo (7.4V) (8.4V fully charged). It started up and works.

If I start it up without a reciver attached to it to give him a position/speed signal it blinkes the same way red.

And it blinks red when I start it up in a postion/speed state that is not neutral, till it gets his neutral(0 speed). Neutral is something like a 1,5ms pulse, from what i read from wikipedia. https://en.wikipedia.org/wiki/Servo_control

So there are two things to try out, decrease the voltage to something like 10v and try if it solved it. Or check how you are sending you speed value to the controller and if you have sent a neutral speed at the beginning.

Hope that helps a bit, even it the answer is quite late.

\$\endgroup\$
1
  • \$\begingroup\$ Thanks for the answer! \$\endgroup\$ – Namboo3 Mar 2 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.