Trying to progamm LCMXO2-256HC-4SG32C with this ebay progammer.

The programmer works fine with LCMX02-1200HC-4TG144C, but with LCMXO2-256HC-4SG32C it gives me the following output:

Starting: "pgr_program run"
INFO - Check configuration setup: Start.
INFO - JTAG Chain Verification. No Errors.
INFO - Check configuration setup: Successful.
INFO - Device1 LCMXO2-256HC: FLASH Erase,Program,Verify
ERROR - Process Operation Failed.
INFO - Elapsed time: 00 min : 01 sec
ERROR - Operation: unsuccessful.
ERROR: pgr_program failed.
ERROR - Programming failed.

This is the 3rd chip I'm trying this with with the same result. I had chips ordered from Alibaba and thought the chips had some issue but now I've ordered a couple from Arrow and these give the same error.

The programming does complete successfully with an earlier version of the Lattice Diamond programmer (v3.8) but then a simple test blinky doesn't work, just no output on the pins, they sit a 0V with the current chip, with the previous chip it was more weird where it would allow to output high on one pin but not on the other and would act as if there was no clock input.

I've checked the clock from the 50MHz oscillator and it looks fine. The soldering also looks fine.

The same simple test works with my other test board with LCMXO2-1200HC-4TG144C.

Have I just fried the chip?
Is this an issue with my programmer?

  • \$\begingroup\$ Are you sure that the chip you are programming exactly matches the chip selected in the Diamond programming software, including all of the suffixes? \$\endgroup\$ – crj11 Mar 15 '19 at 20:10
  • \$\begingroup\$ Yes, pretty sure, and the programmer auto-detects the chip. \$\endgroup\$ – axk Mar 15 '19 at 20:35
  • \$\begingroup\$ Is the programmer detected as an FTDI based programmer? \$\endgroup\$ – crj11 Mar 15 '19 at 21:32
  • \$\begingroup\$ Yes, it detects it as HW-USBN-2A, I suppose it is an FTDI based programmer. \$\endgroup\$ – axk Mar 15 '19 at 21:35

It is software problem with last Diamond SP3 version. As workaround try to change file XO2_256.svp from SP2 My Linux path is: /usr/local/diamond/3.10_x64/data/vmdata/database/xpga/xo2


The programming does work with Lattice Diamond Programmer

It does not work with Lattice Diamond Programmer and the HW-USBN-2A ebay cable failing with "ERROR - function CHECK_SECURITY_PROTECT_KEY"

I thought it didn't work when programmed successfully with because of my bad soldering (D'oh!)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.