0
\$\begingroup\$

I have the output of a wheatstone bridge going into an ADS1115.

I am exciting the bridge with a 24VDC supply and the ADS1115 with 3.3VDC through a Raspberry Pi.

The issue I am having is that when I look at the output from the bridge I see around 6.5mV and as soon as I connect this to the ADS there is no output.

Nothing can been seen through my software even if I turn the gain up to the maximum.

I have tried commoning the grounds of both of my supplies and still no joy.

I was wondering if anyone else had seen this issue and could shed some light on this.

\$\endgroup\$
  • 1
    \$\begingroup\$ Welcome to EE.SE - when asking about circuit operation, it helps if you can provide a schematic and identify all the items as this will attract better answers. If the bridge is an off the shelf component, please identify it. \$\endgroup\$ – Peter Smith Mar 21 at 11:20
  • \$\begingroup\$ What are the bridge outputs relative to ground? I bet they're much more than 3.3v when disconnected, and maybe 3.9v when connected to your ADC. \$\endgroup\$ – W5VO Mar 21 at 11:29
  • 1
    \$\begingroup\$ What does "no output mean?" Zero? Or no values at all? Does your ADC work if you connect it to other signals? \$\endgroup\$ – JRE Mar 21 at 11:42
  • \$\begingroup\$ The ADC does work as i have tested other signals when the brige is connected there are no values given it is outputting a "0". I do apologise for the vaugeness of my description. \$\endgroup\$ – Shak Jamil Mar 21 at 11:59
1
\$\begingroup\$

I am exciting the bridge with a 24VDC supply

The nominal open-circuit voltage on each output from a wheatstone bridge is usually about 50% of the excitation voltage. This is because the bridge acts like two potential dividers.

I would expect to see about 12 volts on each open-circuited output with respect to common ground. It will be lower if you still have the ADS1115 connected.

This almost certainly means that the ADS1115 is presented with input voltages that are far higher than it can cope with. If you are fortunate, the device may not be damaged but this is by no-means certain. To check whether the maximum input current rating of 10 mA has been exceeded, you need to post a schematic.

\$\endgroup\$
  • \$\begingroup\$ Thank you for that, thats explains everything. As my bridge has a resistance of 1400R per leg the current should not have exceeded the 10mA. \$\endgroup\$ – Shak Jamil Mar 21 at 13:48
  • \$\begingroup\$ @ShakJamil If each element is 700\$\Omega\$ it is equivalent to a 12V source with 350 ohm source resistance, so ~18mA per input (assuming Vcc stays at 5V). \$\endgroup\$ – Spehro Pefhany Mar 21 at 14:49
  • \$\begingroup\$ Sorry, each element is 1400 Ohms \$\endgroup\$ – Shak Jamil Mar 21 at 16:32
  • \$\begingroup\$ The equivalent circuit of one arm of the bridge is therefore 12 volts via 700 ohms (1400 || 1400 = 700) and if this output node is dragged down to 3.3 + 0.7 volts, the current flow is (12 - 4)/700 = 11.43 mA. So, this means that you have exceeded the absolute maximum ratings and you should be wary of future anomalies when using this same part. This is based on the ADS1115 supply being 3.3 volts and the input protection diode will permit a further 0.7 volts. \$\endgroup\$ – Andy aka Mar 22 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.