When I create a symbol in the symbol editor and then drop it into a schematic, many of the fields (Value, custom fields) are automatically moved outside the bounding box of graphical objects. enter image description here

In the image above, I have an emergency off button. I've placed the value (EMO) and custom PN field (A02ESI...) inside the "mushroom" in the symbol editor. When I drop this part into a schematic, ALL of my fields are moved. ??? Excuse me? I went through all of the trouble to make a good looking part and then I have to go an manually move all of the fields. Is there any way to better control this behavior?

  • \$\begingroup\$ The reason why this feature exists is that it enables you to rotate or mirror the symbol while the reference and value fields stay readable. It is also needed for multi unit symbols where units have a different size (there is no way to define the positions differently for units) \$\endgroup\$ Mar 28, 2019 at 15:57

1 Answer 1


This is due to "Symbol Field Automatic Placement". You can turn this off in the Eeschema preferences panel as shown below:

Automatic Placement

  • \$\begingroup\$ Yes. Great answer. It's unfortunate that there is no tooltip for this option. \$\endgroup\$
    – bfris
    Mar 26, 2019 at 19:51
  • \$\begingroup\$ Well report the missing tooltip as a bug \$\endgroup\$ Mar 28, 2019 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.