1
\$\begingroup\$

I have a device which doesn't turn on normally when you press the power button like it did before. You have to keep holding it down for it to remain on. As soon as you let go, it turns back off.

In troubleshooting so far I've ruled out some of the simpler things like power supply issues, button seating/placement, loose connectors, etc.

My device happens to be an Alesis DMLite drum machine, but I'm hoping this will have broader applications than just my specific situation. I've seen this happen with other devices before. I know this site isn't supposed to be about consumer electronics but I want to make this relevant by trying to learn more about how this circuit actually works.

So the buttons seem to be pretty simple. They are basically just pieces of rubber seated ontop of a few pads on the PCB.

Here is a picture of the front panel:

Front Panel

And the back of the buttons:

Back of buttons

And some pictures of the boards (first one is where the buttons connect):

Button PCB

Button PCB Back

Main PCB

Main PCB Back

I followed the traces for the power button and one of them ended up connecting to R103, and R104 (both on lower terminal shown in the picture):

Components where button connects

It's hard to find where the other end of the switch connects since the traces/vias aren't visible the whole way through. I was poking around with a continuity meter but haven't been able to find where it goes. But neither trace connects to ground.

On the back of that PCB it's a bit easier to trace the signal. Haven't been able to find a datasheet for the SOTs.

Back section

So this is what I've been able to trace out so far (lots of guesses esp. on pinout here). I've tried to put in some values based on rough in circuit measurements.

schematic

simulate this circuit – Schematic created using CircuitLab

I'm curious if this resembles a common circuit that one of you may recognize. I'm not familiar with this method of switching power. Can anyone shed some light on what this circuit might be doing and how it might malfunction and exhibit these symptoms?

\$\endgroup\$
1
\$\begingroup\$

I suspect the circuit is not exactly like you have drawn (not surprising, due to the difficulty reverse-engineering the PCB). I suspect Q101 might be a PNP transistor to switch the supply to the regulator, and both the push switch and an MCU output signal can drive Q102 base, to pull Q101 base low and switch it on.

how it might malfunction and exhibit these symptoms?

On some systems with an MCU (like your drum machine), the push-button only applies power as long as it is pressed. Assuming the MCU starts quickly e.g. 10s or 100s of ms, one of the first things the MCU does is to output a signal to keep the device powered on, even when you release the push button. (There are alternative techniques for when the MCU takes longer to boot, than the time you want the user to keep the button depressed.)

This "soft power switch" approach also allows the MCU to power itself off (e.g. if it detects battery low, or needs to save power, or any similar feature). You can probably see where I'm going:

  • No output from MCU to keep the power on = device powers off, as soon as the push button is released - exactly as you describe.

The problem is that any MCU-related malfunction can cause that type of behaviour, since the MCU must be operating normally for its code to run and set the signal to keep its own power switched on. Any hardware or software problem that causes the MCU not to run its code (e.g. failed firmware update, clock problem, reset problem - basically anything wrong) means that the MCU doesn't keep its own power switched on.

To test for this theory - does the device keep running correctly if you press and hold the "soft power" button? If no, then this hypothesis could certainly be true. If yes, then this hypothesis could still be true, but the range of possible faults are much smaller, if the MCU is basically running OK while you keep the button pressed. This might be pointing more towards a problem in the "soft power switch" circuitry instead.

A proper diagnosis (especially remote diagnosis) would probably need a schematic, although the test above (and using a scope to look for signs of MCU life, as well as more reverse engineering of the "soft power switch") might allow you to make some progress. IC102 on the bottom of the PCB might also be a regulator or other power device, and might therefore be worth investigating.

\$\endgroup\$
  • \$\begingroup\$ Thank you for your detailed response, this is a big help! From what I can tell, the drum module works normally while I hold the power button down. I can select different patches and the LCD shows the correct number that corresponds to the button I push. I haven't yet tried to get any audio out, I'll try that next once I get home. But the fact that the LCD and other buttons seem to behave normally makes me think the MCU is mostly working okay. I've emailed the manufacturer, maybe I can try a firmware update or something before digging too deep into this thing. \$\endgroup\$ – Avid Pro Tool Mar 29 at 20:07
  • 1
    \$\begingroup\$ @AvidProTool - You're very welcome. As it works when you hold the button down then, if my hypothesis of the design is correct, it would help if you can find the signal from the MCU which keeps the "soft power" circuit switched on, when you release the button. Look for any PCB traces coming from the MCU area towards Q102. I suspect that Q101 emitter connects directly to the power input (not via R107), but R107 does connect the emitter to base (to keep Q101 "off" until Q102 pulls the base low). Also consider that Q101 and Q102 might be MOSFETs. PS I doubt it needs a firmware fix. \$\endgroup\$ – SamGibson Mar 29 at 20:28
  • \$\begingroup\$ I temporarily shorted the pads for the power button together to do some more testing. IC102 seems to be okay, it's putting out 3.3V. I'm not exactly sure which IC is the MCU, I think it's either IC702 in the bottom left corner of the main PCB or IC203/IC202 on the back of that board. Haven't had much luck googling these part numbers or finding datasheets. \$\endgroup\$ – Avid Pro Tool Mar 29 at 21:09
  • \$\begingroup\$ Update: my temporary workaround seems to be working well enough to record and use this thing for a while at least. I'm getting audio and everything seems to be normal so far. It'll even show up as a MIDI device when I connect to my computer. Maybe the issue is something specific to the circuitry surrounding the power button rather than a larger issue with the MCU or something else? \$\endgroup\$ – Avid Pro Tool Mar 29 at 22:19
  • 1
    \$\begingroup\$ @AvidProTool - Last reply for today (now end-of-day here). IC201 is the MCU (mentioned on another forum here). I haven't investigated further, as I can't do any sensible amount of reverse-engineering without having the PCB in my hands (the photos are good, thanks, but just not enough - I've done lots of reverse-engineering, but complex remote RE isn't fun). Yes, based on that result of my suggested test, problem might be closer to the "soft power" circuit - you'd need to make an accurate schematic of that part, to progress IMHO. \$\endgroup\$ – SamGibson Mar 29 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.