I'm using a trial on Altium, where for I guess support ignores me (Altium Designer version 19.0.14).

(I really hope it's better for real users if someone can confirm that, it would be most appreciated)

Back to the question: I want to change all the mils units to metrics.

I found this guide:


However, it doesn't seem to work. If I change the primitive to "MMs" I can't apply them unless I do some other changes as well, however, the settings won't apply anyway, it's still stuck with Mils.

Is Altium like this or can it be changed?

enter image description here


1 Answer 1


Unfortunately, AD does not really apply schematic primitives as metric (the reasons are historical).

I can get the 'apply' button to activate if I select (or de-select - weird) 'Permanent' AD19 primitives options

But when I re-open the settings, it has reverted.

AD19 primitives after re-opening

I believe this is due to the schematic library editor only working consistently in imperial units.

The grid and schematic measurement units do apparently save as metric but opening a new schematic from a template with mm defined as well as the global settings at mm: My default template below.

AD Schematic template preferences

When I actually instantiate it I get this:

AD new schematic from template

In mils, as you can see.

I can change this by using 'View' -> 'Toggle units' AD schematic after toggle units

But this needs to be applied on a per schematic page basis. This is a sticky setting and remains in this setting during document open / close and an AD restart.

The issue I get, though, is that because the grid is metric a lot of 'off-grid' warnings appear.

I usually just leave the schematic in imperial mode to avoid the hassle. The PCB editor is much better in this respect, but is based on a per PCB basis.

If you set the default template to metric (my default below)

PJS PCB template

Then adding a PCB will bring it in as metric. As this is really the one place I need to ensure metric, I just live with the schematic issues.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.