3
\$\begingroup\$

I designed a boost LED driver based on TPS92691. It drives 56V 5A COB LED from 22-50V input. It works ok.

Oscilloscope shows small spikes on input (100mV), but large spikes on output (3V). The spikes are from switching (400 kHz).

I started with 4.7uF X7R output capacitor. Then added one more, spikes were reduced. Then added one more, which reduced spikes little more, but adding more capacitance does not change anything anymore.

I mesure with probe with wire coiled around it.

The switcher is powered by separate 12V power, it has 10uF and 1uF caps right next to Vin pin. Every IC has caps near them. Output caps are close to LED wires.

As I understand it, the spike (ringing) happens when MOSFET starts conducting, then when it opens, second, smaller one happens.

Can the spikes be reduced somehow? Also, is it bad, will it harm anything?

The datasheet

Schematic

Probe Output spike Output spikes

Notes

\$\endgroup\$
22
  • \$\begingroup\$ Seems many things are going on at the same time on the PCB. Can you perhaps draw on it and show which capacitor bank is which and which part is your main TPS92691? If it’s the guy in the middle, your input and output capacitor banks looks very far away. \$\endgroup\$
    – winny
    Apr 13 '19 at 8:56
  • \$\begingroup\$ Added the details \$\endgroup\$ Apr 13 '19 at 9:05
  • \$\begingroup\$ Thanks! Your input and output caps are way too far away! Can you scrape some solderresist away near the switcher to expose Vin and Vout and a nearby GND via and place several caps there? Also, at these high voltages, plastic film comes to mind. \$\endgroup\$
    – winny
    Apr 13 '19 at 9:34
  • 1
    \$\begingroup\$ Can’t see it. Output caps needs to be within mm of the output choke. LED wires location in s not a concern. \$\endgroup\$
    – winny
    Apr 13 '19 at 10:18
  • 1
    \$\begingroup\$ I just read the datasheet. Still mighty strange. But non the less, take a look at page 38 under layout recommendations. Please note that output capacitor is placed just a few mm from the output inductor and the input cap is just a few mm from the transistor. Time for you to start scraping solderresist! \$\endgroup\$
    – winny
    Apr 15 '19 at 7:46
1
\$\begingroup\$

Your spike is common on hard switched power supplies .It is probably the mosfet ,PCB,coil ,diode capacitance resonating with parasitic inductance in the PCB and in the semiconducter bonding wires .Try gate resistance ,Try better PCB layout,Try DS RC snubber .If you do not improve things you will fail radiated EMC .

\$\endgroup\$
0
\$\begingroup\$

The large current spikes are due to operating in the discontinuous conduction mode (DCM) which is inherently noisy at high currents.

Suggestion: Change the design to operate in continuous conduction mode, CCM will reduce the dI/dt significantly from a fast switch transient< 4ns to dI/dt=V/L for the flyback choke slew rate.

Thus if the current slew rate can be reduced such that the bandwidth BW is less than the spurious resonance BW< 0.35/Tr for risetime Tr, there a good chance of noise reduction.

I would guess is an LC tank circuit on the board layout from switched ground path length and Coss FET output capacitance, but non-contact shorted tip probe methods can sniff the current loop to identify the DCM components ( which is also stated in the datasheet).

The 125MHz ringing appears to be the self-resonant (somewhere) that may be located by shorting the 10:1 probe tip to ring and sniffing near-field current transients as a loop antenna.

is it bad

YES. If this ever becomes a commercial product, it must be certified against unintended radiation to be CE compliant. Radiating near 120 MHz may interfere with Airport Receivers for example.enter image description here ;)

\$\endgroup\$
11
  • \$\begingroup\$ Simulation and measurements show, that it operates in continuous mode. \$\endgroup\$ Apr 22 '19 at 12:19
  • \$\begingroup\$ THen with shorted probe where is the spike strongest (sniff around), it is not possible.\ for it to be continuous.\ for then there would be no spike. There must be a missing or poor operating clamp diode to decay current slowly. \$\endgroup\$ Apr 22 '19 at 12:20
  • \$\begingroup\$ I do not know how to use shorted probe. Will read about it and try later. \$\endgroup\$ Apr 22 '19 at 12:21
  • \$\begingroup\$ just make a small 1 cm diameter loop antenna and sniff around wires for signal \$\endgroup\$ Apr 22 '19 at 12:22
  • \$\begingroup\$ Is that a 1000 uH inductor for the LED V+? with no caps? There is something obviously missing or different on your design that you have not told us about that differs from the original design. \$\endgroup\$ Apr 22 '19 at 12:28
0
\$\begingroup\$

There were many suggestions here, many of which I will implement in the next version of my board.

In this case, during redesign process, I noticed that the resistor on the current sense RC LPF was shorted, so, there was no LP filtering. I am not sure exactly how it was affecting the circuit, but now it looks much cleaner. The same waveform, but without spikes, just the ripple.

Here is the waveform, probed exactly as in the post above, on output capacitor:

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.