We received a set of prototype boards. They have a DC power supply input feeding into a step-down converter, which is built around an RT6224D. It is supposed to deliver 5.0V. The circuit is almost exactly straight from the datasheet, just that the designer chose a 3.3 uH inductivity.

Here is what we have: enter image description here

This is the Typical Application Circuit from the datasheet: enter image description here

The problem is, I get exactly 0V at the output. And I can not figure out why. Even on a quick breadboard reproduction of the same circuit, I still get 0 output. I have this feeling there must be something very obvious.

Do you have any idea what is going on here? I greatly appreciate your help!

Edit to answer SamGibson's questions:

(a) PCB layout: enter image description here

(b) The populated PCB, sorry I don't have an unpopulated board: enter image description here

(c) Someone else did the design and the layout, I am just trying to make it work. The boards came from a domestic manufacturer. I talked with the designer about the issue, he said U6 it must be a faulty chip. On all 5 boards. So I replaced it with a new one, same result.

(d) I don't know where the board manufacturer got the components initially, my replacement was from Digikey.

(e) I can't find any usable signal to scope, VIN and EN are at 12V, all other pins show a flat lines at 0V.

(f) The inductor is an ASPI-4030S-3R3M-T.


Edit 2:

This is my "hotfix" based on the feedback by Randy Nuss and Spehro Pefhany. The originial RT6224D did not work any more, but with a new chip and the 100k resistor, I get the desired 12V:

enter image description here

  • \$\begingroup\$ Welcome :-) Please edit your question to add: (a) the PCB layout from your EDA software; (b) a photo of this part of the PCB - preferably from an unpopulated PCB and a populated one, but add whatever variations you have; (c) explain the history of the design - did you make a working prototype first (if so, add a photo of that) or did you go from schematic straight to these PCBs? (d) where did you source the regulator ICs from e.g. known distributor, or AliExpress/Ebay etc.? (e) have you used an oscilloscope to see if there is any attempt for the IC to start? (f) link to inductor datasheet? \$\endgroup\$
    – SamGibson
    Apr 13, 2019 at 16:08
  • \$\begingroup\$ Thanks for the update. I didn't look further at the start, until that update was available, and the lack of evidence you have been given by the original designer for point (c) i.e the history, is especially revealing - there is no history that the design has ever worked! They seem to have gone straight from schematic to PCB, meaning we have to consider possible design problems, not just layout or manufacturing problems. Looking at it from that perspective, Randy has likely identified the problem. Good luck with a replacement chip, a resistor and a scalpel (X-Acto knife) to rework the PCB. \$\endgroup\$
    – SamGibson
    Apr 13, 2019 at 17:54
  • \$\begingroup\$ That is true, I am not aware of any prototypes between the schematic and the pcb. \$\endgroup\$
    – ChrisH
    Apr 13, 2019 at 18:19
  • \$\begingroup\$ Hi ChrisH, your edit looks like an answer which (slightly expanded) would belong to the answer section? \$\endgroup\$
    – bummi
    Apr 18, 2019 at 19:19

1 Answer 1


I'm fairly certain you're blowing up the chip by applying 12V to the EN pin. According to the data sheet the ABS MAX rating on that pin is 6V. Typically one would use a voltage divider to attenuate the input voltage to a value that would yield around 3V on the EN pin with 12V applied.

  • 4
    \$\begingroup\$ Looks right. I think OP can simply connect it to Vin through 100K. "For automatic start-up the EN pin can be connected to VIN, through a 100kΩ resistor. " \$\endgroup\$ Apr 13, 2019 at 16:58
  • 1
    \$\begingroup\$ Good catch Spehro! I missed that. Adding only one resistor will make the rework much easier. \$\endgroup\$
    – Randy Nuss
    Apr 13, 2019 at 17:20
  • 2
    \$\begingroup\$ Thanks, Randy and Sphero, that is a great point. I had tried this with the very first board I got, lifted pin 4 up, air-wired a 100k to 12V, did not help. But then again, that chip might have been dead from our first attempt to start it up. Will cut some traces, put the 100k on the board, and report back. \$\endgroup\$
    – ChrisH
    Apr 13, 2019 at 18:18
  • 3
    \$\begingroup\$ The chip will be dead. Try bending the lead up before soldering the new one down and bridge 4 to 5 on top of the chip with a 100K 0402 resistor for your "field enhancement". \$\endgroup\$ Apr 13, 2019 at 19:16
  • 1
    \$\begingroup\$ Yes, that did the trick! Thank you so much for your help :) I will add a "revision" photo to the original post. \$\endgroup\$
    – ChrisH
    Apr 18, 2019 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.