0
\$\begingroup\$

I have a problem in my 3 phase inverter circuit output. Below, i've attached an image of my circuit. As you can see, i have 3 outputs. There are R, S, and T. So, i've measured line to line voltage across the 3 outputs. But i have problem with S-T output. With 20 VDC Supply, i got R-S voltage approximate 7 V, same as R-T, but 1-2 V for S-T. I don't know where's the problem, i've checked my MOSFETs and they're all fine, i've no MOSFET heat problem too. But still i don't know where is the problem. Could anyone help me, please?? Thanks in advance.

I've attached my gate driver circuit too, maybe there is correlation between MOSFET bridge circuit problem with gate driver circuit. (i am using IR2112 IC for my gate driver circuit).

3 Phase MOSFET Bridge IR2112 Gate Driver

\$\endgroup\$
  • \$\begingroup\$ Usually a working three phase bridge should output voltages as V1+V2+V3=0 \$\endgroup\$ – Marko Buršič Apr 14 at 8:25
  • \$\begingroup\$ So, what am i supposed to do? Could you give me any suggestion, please? \$\endgroup\$ – Fitrah Hidayat Apr 14 at 8:54
  • \$\begingroup\$ Is this DELTA 3-phase,or YYY 3-phase circuit? \$\endgroup\$ – analogsystemsrf Apr 14 at 10:59
  • \$\begingroup\$ All of those diagonal lines is driving my schematic OCD crazy ;) \$\endgroup\$ – Tyler Apr 14 at 12:47
  • \$\begingroup\$ @analogsystemsrf i think it's Delta because i intend to use this inverter for an induction motor.. \$\endgroup\$ – Fitrah Hidayat Apr 15 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.