0
\$\begingroup\$

I am just trying to on and of an led with rf module. I have tried lots of module but my works end up with same result. When I feed my receiver, with led connected to data out, it always powers the led wheter or not transmitter operating. And when I operate my transmitter led starts to blink(sometimes). I didn't understand what is happening. Can anybody please help. Or you can just tell me what should I try to learn. Sorry for my English. Thanks..

\$\endgroup\$
0
\$\begingroup\$

Without you giving more specifics of your circuit (I don't have the reputation to comment in order to ask) I would guess that you have the anode of the LED connected to your positive voltage source(VCC) and the cathode connected to the data output pin, since the default output of the decoder chip is active high.

It would be helpful if you could edit your question to tell us if you have built your own circuit around the OEM IC, or if you are using a third party's implementation of the chip in their own circuit to which you are then connecting. According to the most elaborate PT2272 data sheet I could find, the decoder outputs active high data. In that case, the LED anode would need to be connected to the data output pin and the cathode connected to ground, as the example schematic in the PDF shows, in order for it to behave as you are expecting. Conversely, if the LED anode were connected to V+ and the cathode connected to the data output pin(hopefully through an appropriate current limiting resistor in either case), then the LED would be lit with no data transmission, and then would turn off when the chip successfully receives a valid trigger transmission, which is what appears is happening in your situation.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.