0
\$\begingroup\$

I'm using ESP8266 ESP-01 for wifi data transfer.

When I send the request for 80 server's port, the data is successfully returned.

REQ: GET / HTTP/1.1\r\nHost: server.com\r\n\r\n

But when I send this request over 443 server's port, the data received is "Recv 50 bytes... ...SEND OK..."

It's possibly an ESP or an HTTPS Headers problem? What i mean is what is needed to transform the Headers from HTTP to HTTPS (I did'nt saw any diference in Postman, but in Postman works only changing the server's port)?

  • Sequence in HTTP:

AT+CIPSTART="TCP","myserver.com\",80"\r\n

AT+CIPSEND=PKG_SIZE\r\n

GET / HTTP/1.1\r\nHost: myserver.com\r\n

Works OK.

  • Sequence in HTTPS:

AT+CIPSTART="TCP","myserver.com\",443"\r\n

AT+CIPSEND=PKG_SIZE\r\n

GET / HTTP/1.1\r\nHost: myserver.com\r\n

Doesn't work.

\$\endgroup\$
3
  • \$\begingroup\$ How many bytes are you actually sending? \$\endgroup\$ – Egor Tamarin Apr 25 '19 at 6:52
  • \$\begingroup\$ The reponse is "Recv x bytes" where x is the bytes sent in my request. The GET above have 50 bytes. \$\endgroup\$ – Henrique Apr 25 '19 at 12:53
  • 1
    \$\begingroup\$ Are you using the AT firmware? Show the AT commands you use. \$\endgroup\$ – JimmyB Apr 25 '19 at 14:13
0
\$\begingroup\$

Try to connect via SSL instead of bare TCP:

AT+CIPSTART="SSL","myserver.com",443
\$\endgroup\$
2
  • \$\begingroup\$ The module reposnds: "busy p...\r\n\r\nERROR\r\nCLOSED\r\n. Ive found in another forum that this model (ESP-01) maybe doesn't support HTTPS... \$\endgroup\$ – Henrique Apr 30 '19 at 0:41
  • \$\begingroup\$ Jimmy, thank you. I tested in ESP32 and worked in 443 PORT. in ESP8266_ESP01 still doesn't work but ESP32 is far enough. \$\endgroup\$ – Henrique May 1 '19 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.