0
\$\begingroup\$

Transmission from atmega32 to PC using max232 not working. When I checked the data from the Tx pin (in the realterm software) of atmega32 it was fine. But there was no output data from max232, when I was trying to read data in the realterm software. I have attached the circuit that I used.Where am I going wrong?

\$\endgroup\$
  • 2
    \$\begingroup\$ Probably unrelated but put decoupling capacitors across all power-gnd pins as close as possible to the pins. 0.1uF ceramic. Measure the voltages on your charge pump caps for the MAX232. Make sure it's working. \$\endgroup\$ – DKNguyen May 2 at 14:56
  • 1
    \$\begingroup\$ Some variants of the MAX232 require much larger capacitors (10 µF). \$\endgroup\$ – evildemonic May 2 at 15:11
  • 1
    \$\begingroup\$ You should compare the physical implementation to a known good MAX232 solution. Also make sure you are measuring the output without a PC connected, and recognize that the line driver will invert the signal from what you see on the logic level side. Also *explain _exactly_ what "no output" means - what voltage do you measure for each input condition? What voltage do you measure on each of VS+ and VS- with respect to ground? Which pin do you believe to be T1 out? \$\endgroup\$ – Chris Stratton May 2 at 16:52
0
\$\begingroup\$

As is mentioned (above) the specific MAX232 chip may need larger capacitors and the polarity of them (usually) is important.

\$\endgroup\$
0
\$\begingroup\$

Check if the voltages at output of level converter are correct by giving logic 0/logic 1 at its input (use a multi meter to check output voltage of level converter). You haven't mentioned about the software used at host side to send/receive data. If you are using any terminal emulator like putty/minicom, check their settings for correct port settings, baud rate settings and make sure that flow control lines (RTS, CTS) are disabled. If all of these are not working, it would be a good idea to check the output of TX line of microcontroller using a logic analyser/oscilloscope. If such a setup is not available, use a loopback connection to ensure that your UART driver can actually send and receive bytes.

Also check if your microcontroller is properly decoupled from power supply.

\$\endgroup\$
0
\$\begingroup\$

I am grateful to all of you for your valuable suggestions. My fault was in the RS-232 to USB converter. I changed it and now I am able to read data in my Realterm terminal software.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.