0
\$\begingroup\$

I am building a SMPS circuit from a switching IC. This IC has feedback and enable pins for timing and current calculations respectively.

SMPS Circuit

Transformer Data: (10 pin 1-5, 6-10) primary: 1-3 - 60 turns, 3-2 25 turns (1-2 is total coil with 1.5 mH) secondary: 6-10 - 7 turns aux: 4-5 - 21 turns

When this circuit is operated in open mode (without load), it gives 5.2V (which is what i need). But when we start connecting load, voltage drops a little up to around 4.8V for some 1.4 A or 1.5 A need (10 ohm 10 W resisters in parallel to make load). If i take total parallel load up to 2.5 ohm, it should ideally give 2A at 5V. But happens is voltage start decreasing to 3 V as current raises to 2 A.

Why is that?

(I have tried using 2 1R0 or 2R2 instead of 2 1R5 for cs/enable but with no result, Also using 10 ohm in feedback after diode instead of 1 ohm)

IC: CT5503s

EDIT: Updated circuit Image

\$\endgroup\$
  • \$\begingroup\$ can you rewrite the second paragraph is very difficult to understand what is happening.And please attach the IC datasheet \$\endgroup\$ – Navaro May 8 at 9:10
  • \$\begingroup\$ corrected few details \$\endgroup\$ – Akshit May 8 at 9:32
  • 1
    \$\begingroup\$ Probably the core approaches to the saturation point as the load current increases. Does the core of the transformer (actually, it's a coupled inductor) have air gap? \$\endgroup\$ – Rohat Kılıç May 8 at 9:38
  • \$\begingroup\$ I do not know how to know that. We built transformer from data given by supplier. We used ferrite core EE 16/8/5. \$\endgroup\$ – Akshit May 8 at 9:44
  • \$\begingroup\$ Where in the device data sheet does it tell you that you can expect a perfectly regulated 5 volts with a 2 amp load? Try adding another 10 uF capacitor after the bridge - the example circuit in the data sheet does have two. \$\endgroup\$ – Andy aka May 8 at 10:14
1
\$\begingroup\$

You have the output (secondary) of the transformer's phase reversed.

\$\endgroup\$
  • \$\begingroup\$ Thats in diagram i guess, in real it's 180 degree. Any way to recheck that? \$\endgroup\$ – Akshit May 8 at 16:26
  • 1
    \$\begingroup\$ @Akshit That ”diagram” and “guess” is a problem to combine in one sentence. If you don’t show 100 % correlation between your schematic diagram with your built circuit, you will have a bad time getting help here, or anywhere else. EEs talk in the language of schematics. \$\endgroup\$ – winny May 8 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.