0
\$\begingroup\$

I am interfacing ADS1282 with LPC1768 through SPI. Currently I am not onnected analog supplies. Only digital supplies connected.I am trying to check whether communication is happening or not.But I can't read the register values.

These are the steps I followed.

1.sent 0x11 for - Stop continuous reading.

2.sent 0x20 for - Reading 1st register.

3.sent 0x00 for reading only on e register.

4.Dummy write 0x00 for reading data.

Given delay 100 microseconds in between instructions. I am getting only 0x00. I checked different registers. SCLK = 3 MHZ

\$\endgroup\$
3
  • \$\begingroup\$ Can you talk to the chip at all? \$\endgroup\$ May 10, 2019 at 12:42
  • \$\begingroup\$ blog.codinghorror.com/rubber-duck-problem-solving \$\endgroup\$ May 10, 2019 at 12:44
  • \$\begingroup\$ The wrong clock polarity might be a reason. Can you monitor communication with an oscilloscope/logic analyzer? It's likely to be more a configuration issue than a hardware problem. You could provide us with some code, but I guess it's the wrong board in that case. \$\endgroup\$
    – Sim Son
    May 10, 2019 at 16:38

1 Answer 1

0
\$\begingroup\$

The datasheet says the chip is internally held in reset until power supplies are valid. Do not partially power chips unless datasheet specifically allows this under some conditions.

\$\endgroup\$
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.