0
\$\begingroup\$

The induction heater was tested using a relay as an ON-OFF switch before and worked so i just want to focus on the MOSFET switch part of the schematic.

When i tested the circuit using a MOSFET switch it worked but after a few tests the OFF state just stopped working. After taking a look at the P Channel MOSFET I noticed that it was always ON even with everything turned off. I suppose something must have burned the MOSFET.

And my question is what may have caused this to happen?

enter image description here

\$\endgroup\$
2
\$\begingroup\$

You blew your PMOS. Semiconductors usually fail short.

You are cutting it real close with your PMOS's max Vgs (25V max). Any ringing or spike and you blow your PMOS gate. My money is on that.

It's so close that 24V zeners or TVS diodes to clamp the gate voltage would not help. Use a 12V or 15V clamping diode instead.

schematic

simulate this circuit – Schematic created using CircuitLab

\$\endgroup\$
  • \$\begingroup\$ Thanks for the information! I'll try making that change in the circuit and see if it solves the problem. \$\endgroup\$ – TJCRodrigues May 13 at 16:53
1
\$\begingroup\$

It's probably inductive kickback when you switch the PMOS off. Put a diode in there; cathode to PMOS drain, anode to ground (so it's reverse-biased when the PMOS is on). When you turn off the PMOS the two inductors will pull current from ground until they're discharged.

\$\endgroup\$
0
\$\begingroup\$

There a re two ways to address your problems:

  1. Put a high power diode across the switched 24V supply
  2. Put a small wattage Zener diode and diode from Drain to ground

You also need to address the V(GS) for the device you used. That alone may be killing your device.

schematic

simulate this circuit – Schematic created using CircuitLab

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.