-4
\$\begingroup\$

I have a problem with my TP4056 circuit.

Schematic

My goal is to (solar)power a NodeMCU V3 with the TP4056. I simply connected the output from the TP4056 to VIN and GND from the NodeMCU board

The TP4056 works fine if the power source (the solar panel) is connected, but if I remove the solar panel, the battery doesn't power the NodeMCU.

The battery is fully charged.

Edit: My idea is that if the power supply is disconnected, the TP4056 will automatically power the NodeMCU via the battery. Can the TP4056 do this? Or is there another/better solution?

\$\endgroup\$

closed as unclear what you're asking by Brian Carlton, winny, RoyC, David, Warren Hill May 16 at 12:38

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    \$\begingroup\$ 1) Include a schematic to explain how you connected everything. 2) Why do you expect the battery to power the TP4056 when the TP4056 doesn't have a power source connected? Would you like the battery to charge itself from its own power through the TP4056? \$\endgroup\$ – Bimpelrekkie May 14 at 19:59
  • 4
    \$\begingroup\$ Schematic is necessary. I am now confused with this new comment. \$\endgroup\$ – Misunderstood May 14 at 20:21
  • 4
    \$\begingroup\$ See how it only creates confusion if you don't add a schematic. No need to paint it or make it to scale, as long as it is clear enough. \$\endgroup\$ – Bimpelrekkie May 14 at 20:42
  • 1
    \$\begingroup\$ The TP4056 is not designed to do what you expect; it is a charger, it is not designed to power a load. \$\endgroup\$ – Chris Stratton May 14 at 21:12
  • 3
    \$\begingroup\$ "The battery is fully charged." - exactly what voltage is the battery, and what voltage do you get on the TP4056 module's output terminals? (with the solar panel and NodeMCU disconnected). Module schematic here \$\endgroup\$ – Bruce Abbott May 14 at 23:13
1
\$\begingroup\$

Your battery maybe have a problem. If there is a 3.3V voltage regulator in the nodemcu you will have to put at least 3.7 volt there. Maybe your battery is not capable of supplying 3.7 volt.

\$\endgroup\$
  • 2
    \$\begingroup\$ This is something to keep in mind, but it is not the primary problem here. The primary problem is that the asker expects the TP4056 to do something it is not designed to. \$\endgroup\$ – Chris Stratton May 14 at 22:36
  • \$\begingroup\$ The battery has 4.2V. I even supplied the TP4056 directly with the battery and it worked. \$\endgroup\$ – Jaijo K May 15 at 16:12
  • \$\begingroup\$ So your nodemcu takes 3.3 volt. There are certain possibilities the regulator has a problem. There seems to be something missing from here. \$\endgroup\$ – Sohan Arafat May 15 at 17:00
  • \$\begingroup\$ Do you mean the regulator of the NodeMCU? Everything work works fine if the TP4056 is connected to a power source. But when I remove the power source, there is no power output. I expected that the TP4056 would power the NodeMCU via the battery. \$\endgroup\$ – Jaijo K May 15 at 17:05
  • \$\begingroup\$ From the image of the nodempu it uses an AMS117-3.3 LDO with a Dropout Voltage of 1.1V typ, 1.3V max. \$\endgroup\$ – Misunderstood May 15 at 22:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.