4
\$\begingroup\$

I am unable to run ltspice simulation. I have tried changing the solver to alternate, adjusting Gmin and Trtol, Changing integration method. Always get the same error.

Error message: Analysis: time step too small; initial timepoint: trouble with schmitt-instance a:u1:4

ltspice circuit

New contributor
Kiepolanie is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
\$\endgroup\$
  • \$\begingroup\$ Have you consulted the experts on the LTSpice Yahoo! group? \$\endgroup\$ – Brian K1LI May 15 at 17:41
  • \$\begingroup\$ It doesn't look like you defined any of the transient analysis parameters \$\endgroup\$ – Oscillonoscope May 15 at 17:47
3
\$\begingroup\$

The solver probably doesn't like the open ports SDCOM and SD on U1. If they really are supposed to be open, put a 1e6Ω or 1e9Ω to ground (or whatever value they should be set to). This helps the solver find the value on those ports.

They are probably high impedance to a gate of a mosfet or something like that, if so, its either a floating net or close to it, floating nets are hard to solve for, so you need a current and a voltage so the solver can solve the net.

\$\endgroup\$

Your Answer

Kiepolanie is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.