1
\$\begingroup\$

I'm using LTspice XVII, and I'm having issues generating components from PSPICE component files. Previously, I was able to follow the method of opening the netlist file, highlighting the name, right click and create symbol, but with this new version, some unexpected issues are causing some problems for me.

For the purposes of this issue, I'm using the PSPICE model of the OPA656 from Texas Instruments (comes in a ZIP file marked sbom136b). After unzipping it, I followed the steps mentioned above, and I've generated a user symbol for the op amp.

Just to run a quick test, I had it set up for the following voltage follower configuration to test if it worked.

schematic

simulate this circuit – Schematic created using CircuitLab

However, when I run it, I get the following errors:

ERROR: Node U1:I0:I21:1:102 is floating and connected to current source G:U1:I0:I21:1:RA

ERROR: Node U1:I0:I19:1:102 is floating and connected to current source G:U1:I0:I19:1:RA

ERROR: Node U1:I0:I19:1:302 is floating and connected to current source G:U1:I0:I19:1:RC

This is causing my simulation to fail, and I'm not sure how to fix this in the PSPICE model file. It's also strange that with previous versions of LTspice, there was nothing wrong. The model hasn't changed, but the version of LTspice has. What can I do to fix this in the PSPICE file if possible?

EDIT: Sorry for not including it before, but here's a picture of my simulation. I've checked my pins, and they were correct, so the symbol isn't the issue. Like one user said, it's probably something in the PSPICE LIB file. The strange thing is that it was working correctly in previous versions of LTspice, like LTspice IV and VII, but with this new version XVII, it's clearly not.

Voltage Follower Error

\$\endgroup\$
  • \$\begingroup\$ There seem to be some problems with GRC and GRA (and surroundings) inside the model definition, I tried adding some 1g resistors to the ground in key points, small caps, Rpar to caps, but it still complains. It does simulate, though, it's just that the error log shows up with warnings. \$\endgroup\$ – a concerned citizen May 17 at 5:58
  • \$\begingroup\$ @aconcernedcitizen Thanks for your reply. Running it like shown with the warnings, I'm not getting the correct voltage. In fact, I'm not getting any voltage at the output at all. I'll include a picture as soon as I can to showcase the simulation with errors. \$\endgroup\$ – user101402 May 17 at 13:08
  • \$\begingroup\$ I managed to make the erros go away, but now running it with IV shows a different output, while XVII shows no output, even on alternate. With the last resort of .opt cshunt=1f, I get output but not what you'd expect from a 70mA output. For my part, models that embed conditionals and heavy behavioural functions are not very reliable. Your experience may differ. \$\endgroup\$ – a concerned citizen May 19 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.