0
\$\begingroup\$

I have a heating system with 10kohm floor temperature sensor cable connected to controller unit. The controller displays floor temperature around 7.0 degC higher than reality, the sensor is installed in a channel inside the floor above insulation and below floor boards (directly between heating elements). I do not believe (although cannot confirm) that the sensor head location is compromised in any way, I can withdraw the sensor from conduit and leave it exposed in the room above floor and the display temperature remains the same. The sensor cable is installed in its complete calibrated length. It is the right sensor resistance for the controller, yet the 7.0 degC discrepancy persists. I've tried swapping controller and replacing sensor. I have adjusted the heating set point upwards to account for the discrepancy; the heating system modulates effectively and the relative temperature tracks correctly, but it annoys me that the controller displays heating at 28 degC when it's really around 21degC (confirmed by thermostat in lounge room). Any ideas what I can test or try next?

\$\endgroup\$
6
  • \$\begingroup\$ I think this will depend on the specific controller unit used. Do you have a manual for it? There might not be an easy way. \$\endgroup\$ – Justin May 23 '19 at 13:03
  • \$\begingroup\$ Thanks, the controller does not support sensor calibration adjustment so if i was going to try to adjust the sensor resistance to fool the controller I would nee to apply the resistance myself, perhaps installing a 15kohm sensor cable, although I have no idea how much resistance to add to make up the 7degC. \$\endgroup\$ – James Coffey May 23 '19 at 13:10
  • \$\begingroup\$ What's the chance you have the wrong model of sensor for your controller? You've replaced the sensor, and you've replaced the controller. Either you have unmatched hardware, or the controllers have a setting or calibration you need to change \$\endgroup\$ – JRE May 23 '19 at 13:45
  • \$\begingroup\$ Unlikely, they came together and the controller terminals are imprinted with 10kohm, as well as being in the user guide... i'll check the settings again, i have verified with the manufacturer that it does not support calibration adjustment \$\endgroup\$ – James Coffey May 23 '19 at 15:18
  • \$\begingroup\$ Have you measured the thermistor with a multi-meter to see if it is indeed reading low? \$\endgroup\$ – sstobbe May 23 '19 at 16:59
0
\$\begingroup\$

7°C is a huge error- typically sensors like that are good to a fraction of a degree C (better than most semiconductor temperature sensors).

The 10K resistance is typically specified at 25°C. If you have a "Beta" spec you can look up the temperature-resistance chart and find the expected resistance at 21°C. For example a beta 25/50 of 3380K (a common type) would have a resistance of 10K at 25°C and about 11.67K at 21°C.

Once you know the expected temperature-resistance curve you can determine where the error lies. My bet would be with the controller, however such a huge error (reading resistance of about 8.9K in this case rather than 11.7K) would imply either something is seriously wrong with the controller or there is some configuration setting that you need to make. Maybe look for a service manual for the controller or contact the supplier.

Just to be absolutely clear on this- with such a large error (assuming no hidden configuration setting you've possibly missed), there's a good chance it's about to fail completely and without further notice.

\$\endgroup\$
2
  • \$\begingroup\$ inclined to agree fault is likely with the controller, not much to go wrong in the sensor cable and i've tried three of them. I tried another controller but i saw no improvement, however it is possible that the source of damage to both controllers could be consistent. \$\endgroup\$ – James Coffey May 23 '19 at 13:18
  • \$\begingroup\$ and i understand your suggestion is to replace controller rather than try to game it, it's certainly an option I will consider... just to add a point of further confusion, i had also replaced the controller with a brand new & different type unit which also demonstrated the same fault... just doesn't add up \$\endgroup\$ – James Coffey May 23 '19 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.