1
\$\begingroup\$

When using the ESP8266-12F on a PCB I designed myself it keeps resetting after a high current spike of another module (Sim800L). I ofcourse tried to solve this using capacitors but I seem to have made a miscalculation.
My calculation is as follows \$C = \frac{I * \Delta t}{\Delta V}\$
With a max ripple current of 0.35 V with a current spike of 2 Amps for 0.6 ms this results in: \$\frac{2 * 0.0006}{0.35} = 3400\$ µF which seems excessive.

Context
I have a total of 1410 µF of capacitance which should only give a The SIM800L is connected to a 700 mAh LiPo battery, its ground is regulated through a IRLZ34N mosfet. The ESP12F is controlling this mosfet by supplying 3.3V to it's gate programmatically. The Sim800 has a SMD tantalum capacitor of 470 µF and 2 other electrolytic caps of 470 µF. The ESP12F gets 3.3V through a HT7333A LDO and has it's own 220µF electrolytic capacitor. The ESP has a operating voltage of 3.3V to 3V (but 2.6V also worked for me) The LDO is powered with the battery.

Problem
The problem is not the Sim module resetting but the ESP module doing so. Should I add ceramic capacitors to filter noise or do something else? Space is of concern so I prefer something small.
I do not have a working scope yet but will have soon (In case I can fix it)
(when I charge the battery everything works just fine so it isn't RF interference)
Some schematics Simplified schematic

Sim800L reference voltage

\$\endgroup\$
  • 1
    \$\begingroup\$ My first step would be to find the real root cause of the issue, adding capacitors is just a "bandage" and doesn't address the underlying issue. What if the battery has such a high internal resistance that its output voltage drops too much when the Sim800 module transmits.Maybe a more reasonable approach would be to charge some buffer caps from the battery through a Schottky diode and feed the LDO from that so that the ESP12 gets a more stable supply. \$\endgroup\$ – Bimpelrekkie May 29 at 11:12
  • 1
    \$\begingroup\$ Also consider that ESP and SIM modules have different grounds. I would never to that as it can create issues (the supply of the ESP can be "pulled up" through the ESD protection diodes in the SIM module, learn more by watching: youtube.com/watch?v=2yFh7Vv0Paw&t=0s). I'd switch on Vbat side or use a disable input on SIM800 (not sure if it has one). \$\endgroup\$ – Bimpelrekkie May 29 at 11:12
  • \$\begingroup\$ And more to consider: Is it a voltage drop causing your problems, or is RF from the SIM800 blowing your ESP offline? \$\endgroup\$ – JRE May 29 at 11:24
  • \$\begingroup\$ Thanks a lot for the anwsers, it has to do with the power and not the RF, when I charge the battery (using a tp4056) everything works fine. I will try to measure the internal resistance of the battery and try to switch the Vbat side. By a disable input do you mean an chip enable pin? \$\endgroup\$ – bart May 29 at 11:44
  • 1
    \$\begingroup\$ Why are you using the mosfet on the ground path instead of the SIM positive rail? \$\endgroup\$ – Unknown123 May 29 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.