0
\$\begingroup\$

I've created a preliminary schematic without any package, because at drawing phase were unknown. So I've used "EXTERNAL" attribute to my devices to allow me to add them to schematics. Now I've added packages to my devices and want to update library to change package of all this devices. But when I'm trying to perform this operation, I get this two errors:

"No mapping between external and non external devices. XXXXX (external) can't be mapped to new version of XXXXX (not external)" where XXXXX is the name of a single device.

enter image description here

I've tried to delete all this devices from schematics and add a copy with a different name. But nothing. Seem that my schematic stuck with old device.

A temporary solution was to create another device with another name. But this create me a redundancy inside my library and also another error:

enter image description here

How I can solve this problem if someone already encounter it?

p.s. I've already tried to contact Autodesk but without answer.

\$\endgroup\$
  • \$\begingroup\$ Have you tried the replace feature? \$\endgroup\$ – Andy aka May 30 at 10:05
  • \$\begingroup\$ I don't know how to use it in this particular case. I've not created a component that I need to replace with another one. It's the same components where EXTERNAL attribute were removed and a footprint were added. After that, button "Update Libraries" or "Add Component" inside schematic editor generate me this error. \$\endgroup\$ – Singed May 30 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.