0
\$\begingroup\$

I am trying to flash an Ambiq Apollo via SWD.

The problem is that my debugger is unable to connect to the board.

Initially, i though that the SWD pins would simply be remapped by software on the MCU. Thus, following this post, i tried to hold down nRST while powering on the board. Yet, no connection possible.

What additional ways are there to disable SWD? What else can i try to enable debugging on my board?

\$\endgroup\$
  • \$\begingroup\$ I'm assuming the board is powered up, right? sometimes people assume that the debugging probe supplies power but normally that isn't true \$\endgroup\$ – diegogmx Jun 17 at 15:20
  • \$\begingroup\$ yes, it is powered up. And furthermore, after releasing nRST ist normally starts its boot proces... \$\endgroup\$ – Daniel D. Jun 17 at 17:38
  • \$\begingroup\$ Ok, let me get the situation clear in my head, Have you ever connected to this board? if so have you reassigned the pins to some other function? what debugger are you using? is it a custom debug cable? have you tried plugging an oscilloscope to the debug lines? \$\endgroup\$ – diegogmx Jun 17 at 22:53
  • \$\begingroup\$ Hi, i will try to explain the situation...I am talking about a board i bought, precisely a Fossil q hybrid smartwatch. I want to develop an Open source SDK for that thing, so that enthusiasts can play around with it, since it has a sensor, and with a battery-lifetime of about half a year provides a lot of possibilities. The OEM seems to have the SWD function disabled, so i am searching for a hack to somehow erase the chip... \$\endgroup\$ – Daniel D. Jun 18 at 13:25
  • \$\begingroup\$ Appendix: they really locked out the debugger function, they did not simply remap the pin functions, so the nRST-hack does not work... \$\endgroup\$ – Daniel D. Jun 18 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.