1
\$\begingroup\$

I am a chemical engineering student. I need to control a valve and pump system using an Arduino Uno.

I was testing out my 12V DC solenoid valve with a variable DC power supply, and noticed that the solenoid valve would not open, I hear a clicking noise though.

In another question posted on this forum, a user stated that a minimum pressure is required to open the valve. Pressure should not be an issue according to the data sheet provided here:

https://www.mantech.co.za/datasheets/products/91741-R0.pdf

Thank you in advance.

Edit: The question is why isn't the solenoid valve opening when the required voltage and current is applied across the terminals?

Edit2: Thank you Drew! Despite it not being on the data sheet it does require an operating pressure higher than I was delivering. Simply applying the pressure using my mouth opened the valve.

\$\endgroup\$
  • \$\begingroup\$ do you have an actual question? \$\endgroup\$ – jsotola Jun 12 at 15:47
  • 1
    \$\begingroup\$ Solenoids are polarity sensitive; do you have the polarity correct? \$\endgroup\$ – Hearth Jun 12 at 15:49
  • \$\begingroup\$ How would I find the polarity of the solenoid? I was under the impression that you could connect the power in either direction. Also, no mension of + or - terminals are made available on the data sheet. \$\endgroup\$ – Vivek Jun 12 at 16:28
  • 1
    \$\begingroup\$ If you can hear an audible clicking, then the plunger probably is moving. How are you verifying whether or not the valve is opening? Agree with the others that you should try switching the leads. Also try blowing into it to provide a bit of cracking pressure. \$\endgroup\$ – Austin Prater Jun 13 at 1:11
1
\$\begingroup\$

This is a typical industrial datasheet, in that it's light on the details.

The mechanism isn't obvious from the picture (can't tell if it's a pilot valve), but it probably does need a bit of pressure to open. You haven't told us your operating pressure, but somewhere between 0 and 5 psi may be necessary.

Next possibility is that your valve is broken, but I've never seen a solenoid fail in that manner so I think that's unlikely.

Another possibility is that you've connected the valve in reverse. Depending on the valve, the direction of flow may be important.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.