0
\$\begingroup\$

I've been trying to make a simple audio player using the STM32F302CBT6, however, the VCC and GND pins of the MCU keeps on getting internally shorted when a 3.3V power supply is provided and a faint burning smell starts to come out of it but it does not get very hot to the touch. The PCB was tested for shorts using a multimeter before powering on.

I'm certain that short is due to the microcontroller because desoldering it removes the short from the board.

Initially, I thought it was a soldering problem but all three PCBs which I soldered have had this issue, including a PCB which was soldered with just the MCU, clocks and a 3.3V low dropout regulator, i.e., these components: Components - MCU, Regulator, Clocks The power to the PCB was being supplied by the 3.3V and GND pins of an Arduino Uno connected to my computer via USB.

My PCB is laid out like this (note the ground copper plane was hidden for visibility):

PCB layout

MCU layout

Are there any visible design flaws or issues I have overlooked which could be causing the internal short?

\$\endgroup\$
  • 1
    \$\begingroup\$ What is your question? \$\endgroup\$ – Andy aka Jun 17 at 10:06
  • \$\begingroup\$ Are there any visible design flaws or issues I have overlooked which could be causing the internal short? \$\endgroup\$ – narcissus299 Jun 17 at 10:11
  • \$\begingroup\$ Why is your silk screen on the back? Are you sure the chip isn't somehow mirrored? \$\endgroup\$ – Scott Seidman Jun 17 at 10:47
  • \$\begingroup\$ I'm using EasyEDA and not Eagle and thus components on the back are mirrored in the editor. The traces are routed to the correct pins. \$\endgroup\$ – narcissus299 Jun 17 at 11:09
  • \$\begingroup\$ The chip seems to be mirrored correctly in the PCB prints. The provided view is through the PCB. I still assume it was rotated 180°C before soldering, since the pins 1 marking is very "small" compared to the mark where the plastic for the body was injected. \$\endgroup\$ – theSealion Jun 17 at 11:30
0
\$\begingroup\$

Short: Try rotating the controller 180° before soldering :)

Long: The ST controllers have two marks on the top side, only one is for Pin 1. And most times you choose the wrong one.

The rotation will connect some GND and VCC pins so you get a short circuit.

To identify the right "Pin 1" you could have a look at the chip datasheet in the section Package Information / Device Marking. ( If you could read the text on the chip, pin 1 is in the lower left corner)

\$\endgroup\$
  • \$\begingroup\$ Unfortunately, this is not the cause of the problem as the STM32 I ordered only had a single mark which was aligned properly so that Pin 1 is on the lower left corner. \$\endgroup\$ – narcissus299 Jun 17 at 10:35
  • 1
    \$\begingroup\$ Could you take a picture from the controller solder onto the PCB? (I have never seen a ST LQFP48 chip with only 1 marking :) ) \$\endgroup\$ – theSealion Jun 17 at 11:25
  • \$\begingroup\$ I've uploaded pictures of the PCB here. You can see the chip! :) \$\endgroup\$ – narcissus299 Jun 17 at 12:01
  • \$\begingroup\$ I asked an earlier question about the multiple marks on ST's LQFP64 packages. Interestingly enough, on a subsequent build of my board the same microcontroller only had one marking. \$\endgroup\$ – bitsmack Jun 17 at 16:16
0
\$\begingroup\$

Looks like your pin count pattern goes clockwise instead of the other way. The oscillator pins should be along the left edge, not the top. The oddity in your silk screen being on the back layer suggests some sort of mirroring.

\$\endgroup\$
  • \$\begingroup\$ Since I'm using EasyEDA, the silk screen for components on the back of the PCB are mirrored. However, the traces are not effected and it is being routed as per the design. \$\endgroup\$ – narcissus299 Jun 17 at 11:11
  • 1
    \$\begingroup\$ I don't understand. Be very clear when you answer this. Is your image looking at the side of the board with the chip on it, or the other side? \$\endgroup\$ – Scott Seidman Jun 17 at 11:22
  • \$\begingroup\$ I would guess the view is from the top side but the controller is placed at the bottom. \$\endgroup\$ – theSealion Jun 17 at 11:24
  • \$\begingroup\$ The photos posted in the main post show both the front and back side of the PCB. I hope the pictures of the PCB will help in providing clarification. \$\endgroup\$ – narcissus299 Jun 17 at 12:03
  • \$\begingroup\$ The answer is that the figure is looking from the FRONT of the board, and that the microcontroller is mounted on the back. The power and oscillators are thus placed correctly \$\endgroup\$ – Scott Seidman Jun 17 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.