1
\$\begingroup\$

I'm doing a 3s audio.wav simulation on LTSpice with the following circuit (3 band pass filters and amplifiers): enter image description here

In this example it's boosting the bass and attenuating the highs.

It loads the first second really fast and then it start to take a longer time: enter image description here

When done amplifying the highs it gets stuck in 2s of the simulation.

The error I get is Fatal Error: Analysis: Time step too small; time = xxxxx,timestep=1.25e-15: trouble with u3:qx-instance q:u3:1. Or sometimes it's U6 that fails.

How can I solve this?

Thanks in advance!

\$\endgroup\$
  • \$\begingroup\$ Is it just me or is the input signal trace not actually connected to R3? \$\endgroup\$ – Tyler Stone Jul 4 '19 at 4:11
  • \$\begingroup\$ @TylerStone It is connected, I corrected that on the schematics and it's exactly working like before. \$\endgroup\$ – FelipeMedLev Jul 4 '19 at 4:46
  • \$\begingroup\$ Falstad can do this in real-time with no wait time and only takes as long to draw the schematic with slider POTs et al. it’s worth learning how. Spice is so slow unless you reduce sample quantum time to 100x your maximum frequency. \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Jul 4 '19 at 5:00
  • \$\begingroup\$ Try adding Rser=0.1 Cpar=1m to the supplies (builtin parasitics). Maybe also Rser=1 to the signal source, as well. \$\endgroup\$ – a concerned citizen Jul 4 '19 at 17:24
1
\$\begingroup\$

When I had some issues like yours I just put this directives:

.options gmin=1e-10 abstol=1e-10 method=gear

It will change the toleration standards for your simulation, but not so much that will affect your result.

\$\endgroup\$
  • \$\begingroup\$ Thanks. It did help, but it still cant finish the job. \$\endgroup\$ – FelipeMedLev Jul 4 '19 at 4:45
  • \$\begingroup\$ Continue to adjust error limits. It will not affect the displayed results which are low resolution not 200dB range \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Jul 4 '19 at 5:03
  • \$\begingroup\$ Could post your .tran directive? I see that Sunnyskyguy EE75 talked about your sampling time. If your sampling is too high on your .tran you can try changing it to something like 1/1000 to start and adjust accordingly you see fit \$\endgroup\$ – Igor Jul 4 '19 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.