1
\$\begingroup\$

I’m having trouble with a circuit I designed and I would be greatly appreciative if I can get some help here.

The circuit I designed is a buffer amplifier type design intended to take two channels of audio input from a passive monitor controller, sent to either the resistor circuit, or low pass filter (as seen in the schematic), and then to the second opamp (which has a trimpot to control DC offset for each channel), and then sent as an audio output at unity gain (or near unity gain). The circuit is powered with +/-15VDC, taking a 36 VDC power supply and sent through a virtual ground type divider and regulated with 7815 and 7915 voltage regulators (although I’ve tried disconnecting the power section and using a bench power supply setup to provide + and – voltages with the same problems).

I designed the circuit using the falstad applet and I’ll attach the text for the circuit so you can see for yourself how I imagined it would work, and I’m attaching images of my schematic, screenshots of my oscilloscope, and images of my soldered perfboard circuit.

When I try to input a 120Hz, +/- 2V sine wave with my function generator, all I get from the output is a mostly flat voltage. It wiggles and shows occasional noise and whatnot when I try tuning the trimpot, but what you see in my image is basically the gist of it. In addition, the opamps (OPA2604APs) get a little warm, which I don’t think is a huge problem, but the 7815 gets pretty hot.

https://imgur.com/a/Q97WvE3

Schematic: Schematic Regulated Virtual Ground Circuit: Regulated virtual ground circuit Top View: Top View. Power circuit/regulated virtual ground with +/-15 VDC output. Channel 1 and Channel 2, Buffer amplifier/filter: Channel 1 and Channel 2, Buffer amplifier/filter One channel buffer/filter: One channel buffer/filter.

(The question editor is now telling me that I need more "reputation" to post more links. You can find all the images at the imgur URL that I posted at the end of my description.)

Falstad circuit simulation

The following are URLs for the relevant datasheets:

media.digikey.com/pdf/Data%20Sheets/Texas%20Instruments%20PDFs/OPA2604.pdf

hep.upenn.edu/SNO/daq/parts/lm7815.pdf

hep.upenn.edu/SNO/daq/parts/lm7915.pdf

vishay.com/docs/28193/mkt373.pdf

globalsources.com/gsol/I/Slide-switch/p/sm/1142899729.htm#1142899729

\$\endgroup\$
  • \$\begingroup\$ Please upload the images using the image button. That way all the information is in the one place. \$\endgroup\$ – Transistor Jul 6 '19 at 9:39
  • \$\begingroup\$ Use a DVM, and measure from Gnd to +15, and then from Gnd to -15. \$\endgroup\$ – analogsystemsrf Jul 6 '19 at 9:43
  • \$\begingroup\$ Paste Falstad URL without short link which failed, tinyURL's work in comments however \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Jul 6 '19 at 13:56
  • \$\begingroup\$ You have, I hope, tried to trace the signal through the chain? What does the output of the left-hand op amp look like? \$\endgroup\$ – WhatRoughBeast Jul 6 '19 at 14:55
  • \$\begingroup\$ Use insert link icon to paste \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Jul 6 '19 at 15:22
0
\$\begingroup\$

Your question lacks details of the Virtual ground in the schematic and BOM.

In combination with a Capacitive load ( which you did not shown unless you follow the datasheet recommendations, ) it could be oscillating.

  • include full URL with keyword using Link icon.
  • comments can use tinyurl.com not sure about yours but it fails.
  • always include full schematic with BOM ( bill of material) and URL links to pertinent parts.

  • I haven't seen a BB part in 30 yrs and I wonder, did they get divorced from TI? Or did you have a cache of old parts? or is it just the BB laser print on the IC? https://media.digikey.com/pdf/Data%20Sheets/Texas%20Instruments%20PDFs/OPA2604.pdf

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ @analogsystemsrf I measured the + and - voltage from ground, and for the positive voltage, I'm getting between 13.69VDC to 15.12VDC depending on how I tune the trimpots on the buffer circuits. For the negative voltage, I'm getting -15.06VDC. \$\endgroup\$ – fas11030 Jul 7 '19 at 0:11
  • \$\begingroup\$ Sunnyskyguy EE75 I updated the falstad link, added more datasheets for the devices I'm using, and added the schematic for the virtual ground circuit. Could you please explain what you mean by the capacitive load? I see, now that you mention it, that there is a section in the datasheet which describes this, although I don't quite understand how it applies to this circuit. By the way, the resistors to ground on the output of the circuit are just an approximation of the load resistance and are not actually part of the circuit. \$\endgroup\$ – fas11030 Jul 7 '19 at 0:21
  • \$\begingroup\$ Your Falstad link is too long due to content \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Jul 7 '19 at 12:29
  • \$\begingroup\$ all you need is an Op Amp for Vdd/2 and not dual LDO’s \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Jul 7 '19 at 12:49
0
\$\begingroup\$

Your 15V regulator is not regulating probably because the input battery voltage is not 15V + 2V + 15V + 2V= at least 34V. Each 15V regulator needs an input of at least 17V.

| improve this answer | |
\$\endgroup\$
  • 1
    \$\begingroup\$ Like I said in the description, I'm using a 36V power supply. \$\endgroup\$ – fas11030 Jul 7 '19 at 1:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.