0
\$\begingroup\$

I am trying to simulate a simple inverter in verilog using modelsim 10.7 version. While compiling the code I am getting the -novopt error (error code 12110). As per user manual page 80; the -novopt argument is to be removed from vlog, vcom and vsim commands and from voptflow variable in the modelsim.ini file.

To remove the error, I set the voptflow variable to '0!' but could no find this argument for vlog, vcom and vsim commands. Pls. tell me how to go about solving the issue so that I dont get the error. I am attaching a snapshot of the error popup and my modelsim.ini file here.

Modelsim.ini file doenload link:

http://s000.tinyupload.com/?file_id=88953175349637767605

enter image description here

Thanks in advance.

\$\endgroup\$
4
  • \$\begingroup\$ Why are you using -novopt in the first place? \$\endgroup\$ – Dave Tweed Jul 11 '19 at 12:44
  • \$\begingroup\$ Thanks for the reply. I am not using the -novopt option. I just installed the tool and tried the first simulation and ran into this error.It is most probably set as a default option and I am not able to remove it. I just want to run verilog and systemverilog codes. Pls. help. \$\endgroup\$ – Arvind Gupta Jul 11 '19 at 15:39
  • \$\begingroup\$ Don't remember the GUI flow, but from command line you should be able to compile using vlog -work work file_name.v and then run vsim work.file_name for simulations. \$\endgroup\$ – rvkrysh Jul 12 '19 at 1:17
  • \$\begingroup\$ Thanks @rvkrysh for your response. I am new to the tool and hence looking for the GUI option. \$\endgroup\$ – Arvind Gupta Jul 12 '19 at 6:49
0
\$\begingroup\$

you should enable the vopt flow. you can do that by going to view >> properties >> VHDL >>> and check the "use vopt flow" option.

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.