1
\$\begingroup\$

schematic

simulate this circuit – Schematic created using CircuitLab

Backstory:

Ok, so I thought that a making a PWM controller would be a fun weekend project, it's been a week now and I still can't make it work properly. The circuit I'm using is from this website.

The problem:

The circuit works perfectly with "small" motors e.g. 12V fans, 9V hobby motors and so on. When I connect a "bigger" motor such as the one from an electric drill or even RC car motors it just doesn't work. I can hear some humming and buzzing comming out of them but they won't even turn.

  • I've tried changing the frequency to no avail.
  • I know that the pwm signal works by hooking up leds and fans.
  • I've tried switching the mosfet for other ones laying around and still nothing.
\$\endgroup\$
  • \$\begingroup\$ Welcome to EE.SE! Please draw a schematic using the built in editor here. Press edit and click on the schematic symbol. \$\endgroup\$ – winny Jul 13 at 10:49
  • 2
    \$\begingroup\$ Please add the circuit schematic (with attribution) into your question so we don't all have to follow a link to understand the question. You just have to post the image URL into the image dialog. \$\endgroup\$ – Transistor Jul 13 at 10:49
  • 1
    \$\begingroup\$ Can your 12V source drive these motors at all? \$\endgroup\$ – Marcus Müller Jul 13 at 11:08
  • \$\begingroup\$ If you are using a lower voltage supply for these "big" motors that could be part of the problem. Numbers and details are required! \$\endgroup\$ – Spehro Pefhany Jul 13 at 11:14
  • \$\begingroup\$ I've added a schematic now, sorry for the inconvenience. Yes my power supply can drive these motors if I directly connect them to the output leads. \$\endgroup\$ – user103320 Jul 13 at 12:42
2
\$\begingroup\$

Big motors seem to wreak havoc on circuits because they make so much EMI noise and specifically with your circuit, you're trying to shove some back EMF into your power supply during the off portion of your PWM. If you have a 12 volt lead acid battery around you could try using the battery just for the motor supply and then only connect the ground of the battery to the ground of your circuit, that should isolate the two enough to see if it works (the battery is big and dumb and can accept the inductive spike). If it works then your problem is that your power supply can't accept power back from the circuit (likely) so you need to protect your power supply.

It also may be worth asking, this is a DC brushed motor you're driving right? A brushless motor will not work... I'm not insulting your intelligence, just covering all my bases.

\$\endgroup\$
  • \$\begingroup\$ Great! Some succes! When I hooked the circuit to my cars 12V lead battery the motor(12V DC) started spinning! Although just barely. The motor I'm trying to drive is a 775 drill motor (18V DC) and it started to spin only when I turned the shaft by hand. BTW no harm done :) All of the motors are brushed DC motors. \$\endgroup\$ – user103320 Jul 13 at 15:24
  • \$\begingroup\$ Awesome! Okay so the diode is performing the valuable "freewheeling" role of letting the current in the motor circulate but slow down during the off time but apparently your power supply is sensitive to the voltage fluctuations. There's a few things you can try to keep the same supply: add capacitors at the power supply to help hold the voltage constant (switching power supply might be trying to compensate for the high/low voltages it sees on its output but can't respond fast enough) and add a series RC snubber in parallel with the freewheel diode. \$\endgroup\$ – Kent Altobelli Jul 13 at 16:33
  • \$\begingroup\$ If you have an oscilloscope, it also might be interesting to probe the power supply output to see how it's trying to cope with the motor consuming and essentially regenerating energy into the supply at whatever frequency you're running the PWM. \$\endgroup\$ – Kent Altobelli Jul 13 at 16:47
  • \$\begingroup\$ I've done exactly what you told and it works! Thank you very much! Unfortunately I burnt my oscilloscope while experimenting (not on this project) so I can't check the power supply output. Once again thank you :) \$\endgroup\$ – user103320 Jul 13 at 18:35
  • \$\begingroup\$ No problem glad I could help 👍 \$\endgroup\$ – Kent Altobelli Jul 13 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.