0
\$\begingroup\$
  1. According to PCB shown below, I have a bunch of MOSFETs with HSOF package with 7 pins of source for each and failed to connect EVERY pin to the connector. In other words, when routing the source signal to their destination which is the connector, only one of the pins connects and the others were left unrouted.

  2. The other question is when drawing a polygon with the same signal name, the connection between polygon and DIP pin is too weak to carry high current signals. Is there any option in Eaglesoft to make these kinds of connections strong enough for high current purposes?

enter image description here

enter image description here

enter image description here

\$\endgroup\$
  • \$\begingroup\$ To avoid having unrouted connections, make sure pins/pads are connected in the schematic view. The PCB design view will show unrouted connections as lines. Polygons are just the perimeter definition for a solid copper area. Search for "PCB trace width calculator" to find tools to help you calculate how wide a trace should be based on current, copper thickness, temperature rise, etc. Your polygon needs to meet the minimum width derived from that calculation. Add the relevant portion of your schematic, component values, and specify how much current is "high current" for better answers. \$\endgroup\$ – JYelton Jul 24 at 16:17
  • \$\begingroup\$ Are all the pins connected in the schematic and/or library device? \$\endgroup\$ – Tom Carpenter Jul 24 at 16:30
  • \$\begingroup\$ It looks like pin2 is connected to the large circle with a thin trace, and then 2-3-4-5-6-7-8 are connected with wider traces. DId you want them all connected to the large circle independently? \$\endgroup\$ – CrossRoads Jul 24 at 16:40
  • \$\begingroup\$ @JYelton thank you I will consider these \$\endgroup\$ – milad Chalipa Jul 25 at 7:47
  • \$\begingroup\$ @TomCarpenter yes all of them is connected properly in the schematic \$\endgroup\$ – milad Chalipa Jul 25 at 7:48
0
\$\begingroup\$

To answering question 1 : The problem was on the library. In the symbol there was 7 different pins which was not connected to each other, so the problem was solved by removing them and placing 1 source pin instead of 7 and appending the pins all together in device page. For question 2 : Simply right-click on polygons and select properties, then uncheck the thermal and OK, all the pins will be merging with polygons.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.