0
\$\begingroup\$

I'm making my own board based on Arduino. To power it I use one LIR2032 cell (button cell 3.6V li-ion battery) that's driven through 3.3V LDO voltage regulator. So far I have tried two different regulators:

  • MIC5504-3.3YM5-TR
  • LD59015C33R

and none of them worked, both did not give any voltage at the output. So far I have tried:

  • connecting ENABLE pin to VIN (in the second one could be left floating, PCB has an error design with EN disconnected but I've already corrected it!)
  • replacing part (in case of ESD)
  • correcting joints (in case of cold joints, multimeter shows proper connection)

The voltage regulator is wired the same way as shown in the datasheet

 BP+ is battery input .

The board works when powered via other source of power so it's not the case of it just not working. Trying different batteries and higher voltages did not solve the problem, output still shows 0V. I have no idea what could be wrong, I hope you can help me with that!

If you have any other regulators to recommend please comment, board needs no more than 100mA. enter image description here enter image description here

(Yes component is bigger than the pads :) MIC5504 is slightly larger than LD59015 but I managed to solder it properly)

\$\endgroup\$
  • \$\begingroup\$ Have you measured the load current? Is it withing specs? Even on startup? \$\endgroup\$ – scorpdaddy Jul 25 at 18:52
  • \$\begingroup\$ The battery negative terminal is connected to the same ground, right? Did you measure the battery voltage when is it connected? \$\endgroup\$ – Reinstate Monica Jul 25 at 18:53
  • 1
    \$\begingroup\$ Why does the GND pad of C16 in your PCB layout have an unconnected net "air wire" leading off somewhere? Are you sure that GND of the regulator really is connected to GND of your battery? \$\endgroup\$ – brhans Jul 25 at 19:27
  • 1
    \$\begingroup\$ Suggest you fire up your PCB layout program with the exact design you sent out, and do a design rule check. Make sure you understand every single error it lists (if any). There are two rubber band connections apparently not routed and maybe there's other things too. \$\endgroup\$ – Spehro Pefhany Jul 25 at 20:19
  • 1
    \$\begingroup\$ Ok, problem solved. My temporary connection to ENABLE didn't work but when I soldered it regulator started to work flawlessly. As I said MIC5504 does not need EN pin connected (that's written in the datasheet) but that happened to be false! It has to! \$\endgroup\$ – Poij Jul 26 at 14:43
1
\$\begingroup\$

Pad 3 is not connected to BP+, unlike shown in the schematic. This means EN is disconnected and the LDO won't power up.

I am not certain that the schematic shows a proper connection to the pin, as there is a 90° angle. This may confuse the software enough to not make a connection here.

\$\endgroup\$
  • \$\begingroup\$ That's true, but it's still not working when connected. MIC5504 even does not need this connection. \$\endgroup\$ – Poij Jul 25 at 20:07
  • 1
    \$\begingroup\$ I want to apologize to everyone who I said that EN has to be connected :D I soldered this connection and happened to work! Lesson learned: DO NOT TRUST DATASHEETS! :) \$\endgroup\$ – Poij Jul 26 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.