-1
\$\begingroup\$

I want to install a SDK that is available for the ESP32 arduino. I want to use the esp-idf framework. Is it possible to install the arduino SDK to be used on the IDF framwork. Thanks in advance for any suggestions or recommendations

I want to install the thingstream arduino sdk made for esp32 on the esp32 idf framework. Is this possible and how?

\$\endgroup\$
  • \$\begingroup\$ you should read the README in detail at github.com/espressif/arduino-esp32 I think it's addressed, or you can read / post issues there \$\endgroup\$ – vicatcu Jul 26 at 13:53
  • \$\begingroup\$ @vicatcu sorry I think my question is misleading I got the SDK install and working on arduino version for esp. I want to use that same SDK(arduino version) on the esp-IDF so that I am not coding in arduino. \$\endgroup\$ – JOHNDOE Jul 26 at 16:05
1
\$\begingroup\$

Yes, the espressif libraries from ESP-IDF are actually required to be installed as a prerequisite before your arduino setup will be able to do anything with your ESP32 device.

If you have specific questions while following one of the many guides such as Arduino Setup for ESP32 you should put those into a question.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.